Have some trouble installing ROS in OS X 10.11.3

asked 2016-03-23 05:13:46 -0600

Spencer Shen gravatar image

I do follow the step in the http://wiki.ros.org/indigo/Installati...

But when I do this step : $ sudo -H pip install -U wstool rosdep rosinstall rosinstall_generator rospkg catkin-pkg Distribute sphinx

the error happen like follow: error: [Errno 1] Operation not permitted: '/usr/share/zsh/site-functions/_wstool'


Command /usr/bin/python -c "import setuptools;__file__='/tmp/pip-build/wstool/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-rtS7xB-record/install-record.txt --single-version-externally-managed failed with error code 1 in /tmp/pip-build/wstool Storing complete log in /var/root/Library/Logs/pip.log

I have tried the pip 8.1.1 and pip 1.2.1. And both produce the same error.

Is there anyone can help me. Thanks a lot!

edit retag flag offensive close merge delete

Comments

Did you figure this out?

nitekrawler gravatar imagenitekrawler ( 2016-03-29 19:37:17 -0600 )edit