Ask Your Question
0

Tool for building packages and dependencies from source on os x

asked 2017-02-08 15:39:15 -0500

fastestindian gravatar image

updated 2017-02-08 15:39:57 -0500

Hi,

I'm trying brush the cobwebs off my last from-source build of Jade on my mac - Sierra. I wanted to get the entire turtlebot source (turtlebot_gazebo, _teleop, etc and its dependencies in a workspace and run a single catkin_make to build

Right now I go to the ROS package wiki, clone a package, build, then clone missing packages and go on... until I'm there. most of the time I'm not!

Any thoughts on a ros tool that helps me pull all source packages and dependencies on mac os?

Any help is much appreciated!

edit retag flag offensive close merge delete

Comments

I've tried using rosdep but it crashes with an OSError exception.

fastestindian gravatar imagefastestindian ( 2017-02-08 16:08:03 -0500 )edit

That's not enough information to help, OSError is too ambiguous.

William gravatar imageWilliam ( 2017-02-08 16:29:48 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-02-08 16:07:51 -0500

William gravatar image

You probably want to use rosinstall_generator , see: http://wiki.ros.org/rosinstall_generator

It will get you the complete list of packages you need, recursively, for a given leaf package by looking at its dependencies.

edit flag offensive delete link more

Comments

@William $ rosinstall_generator turtle_gazebo --exclude RPP --rosdistro jade The following not released packages/stacks will be ignored: turtle_gazebo No packages/stacks left after ignoring not released Any reason for this? turtle_gazebo is not in my RPP

fastestindian gravatar imagefastestindian ( 2017-02-08 17:09:54 -0500 )edit

My bad... typo in package name

fastestindian gravatar imagefastestindian ( 2017-02-08 17:11:55 -0500 )edit

No worries, that error either means: it's not released, or it's not in your RPP, or it's a typo :)

William gravatar imageWilliam ( 2017-02-08 17:32:29 -0500 )edit
0

answered 2017-02-08 17:44:06 -0500

fastestindian gravatar image

updated 2017-02-08 17:47:50 -0500

Thank you! Scenario that worked for me (for other sufferers):

$ mkdir src 
$ cd src
$ catkin_init_workspace
$ cd ..
$ rosinstall_generator turtlebot --deps --exclude RPP --rosdistro indigo >turtlebot.rosinstall
$ wstool init -j8 src turtlebot.rosinstall
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-08 15:39:15 -0500

Seen: 47 times

Last updated: Feb 08 '17