Move_base cannot find robot footprint

asked 2016-03-18 11:16:04 -0600

pgigioli gravatar image

updated 2016-10-26 03:49:56 -0600

130s gravatar image

Hi, I am trying to run a gmapping node but I keep getting the error:

You must specify at least three points for the robot footprint, reverting to previous footprint.

I am using a Turtlebot2 and my robot_radius parameter in my /turtlebot_navigation/param/costmap_common_params.yaml file is set to 0.20. I even tried manually setting the footprint to a 0.4 x 0.4 square by setting "footprint: [[0.20, 0.20], [-0.20, 0.20], [-0.20, -0.20], [0.20, -0.20]]" in the same file but then I get the error "Footprint spec is empty, maybe missing call to setFootprint?"

Looking the rqt_console, the error is definitely generated from move_base. Here is my costmap_common_params.yaml:

   max_obstacle_height: 0.60  # assume something like an arm is mounted on top of the robot

   # Obstacle Cost Shaping (http://wiki.ros.org/costmap_2d/hydro/inflation)
   robot_radius: 0.20 #  distance a circular robot should be clear of the obstacle (kobuki: 0.18)
   # footprint: [[x0, y0], [x1, y1], ... [xn, yn]]  # if the robot is not circular
   # footprint: [[0.20, 0.20], [-0.20, 0.20], [-0.20, -0.20], [0.20, -0.20]]
   map_type: voxel

   obstacle_layer:
   enabled:              true
   max_obstacle_height:  0.6
   origin_z:             0.0
   z_resolution:         0.2
   z_voxels:             2
  unknown_threshold:    15
  mark_threshold:       0
  combination_method:   1
  track_unknown_space:  false    #true needed for disabling global path planning through unknown space
  obstacle_range: 2.5
  raytrace_range: 3.0
  origin_z: 0.0
  z_resolution: 0.2
  z_voxels: 2
  publish_voxel_map: false
  observation_sources:  scan bump
  scan:
    data_type: LaserScan
    topic: scan
    marking: true
    clearing: true
    min_obstacle_height: 0.25
    max_obstacle_height: 0.35
  bump:
    data_type: PointCloud2
    topic: mobile_base/sensors/bumper_pointcloud
    marking: true
    clearing: false
    min_obstacle_height: 0.0
    max_obstacle_height: 0.15
  # for debugging only, let's you see the entire voxel grid

#cost_scaling_factor and inflation_radius were now moved to the inflation_layer ns
inflation_layer:
  enabled:              true
  cost_scaling_factor:  5.0  # exponential rate at which the obstacle cost drops off (default: 10)
  inflation_radius:     0.5  # max. distance from an obstacle at which costs are incurred for planning paths.

static_layer:
  enabled:              true
edit retag flag offensive close merge delete

Comments

When do you see this error? Whenever you give any goal to move_base?

DavidN gravatar image DavidN  ( 2016-03-21 06:32:33 -0600 )edit

I get this error when I run the gmapping launch file from turtlebot_navigation. It appears during the initialization.

pgigioli gravatar image pgigioli  ( 2016-03-21 08:54:48 -0600 )edit

Might be related to this: http://answers.ros.org/question/20474...

DavidN gravatar image DavidN  ( 2016-03-30 21:22:38 -0600 )edit