Ask Your Question
0

I am compiling the gazebo_naoqi_control for NAO on Gazebo but getting compilation Error.

asked 2016-03-13 09:08:42 -0600

saleem gravatar image

updated 2016-10-24 09:10:59 -0600

ngrennan gravatar image

I am compiling the nao_gazebo ( https://github.com/costashatz/nao_gazebo ) package for NAO simulation on Gazebo but i am getting compilation error on catkin_make .

Error is :

In file included from /home/saleem/catkin_ws/src/nao_gazebo/gazebo_naoqi_control/src/gazebo_naoqi_control_plugin.cpp:24:0:
/home/saleem/catkin_ws/src/nao_gazebo/gazebo_naoqi_control/include/gazebo_naoqi_control/gazebo_naoqi_control_plugin.h:45:31: fatal error: alnaosim/alnaosim.h: No such file or directory 
#include 
^
compilation terminated.
make[2]: *** [nao_gazebo/gazebo_naoqi_control/CMakeFiles/gazebo_naoqi_control.dir/src/gazebo_naoqi_control_plugin.cpp.o] Error 1
make[1]: *** [nao_gazebo/gazebo_naoqi_control/CMakeFiles/gazebo_naoqi_control.dir/all] Error 2
make: *** [all] Error 2
Invoking "make -j4 -l4" failed
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-03-14 02:01:04 -0600

mgruhler gravatar image

You need to have the Aldebaran NAO Simulator SDK installed and properly set up. There you'll find the missing header file.

Also, check out the Readme of the package you try to build, this actually tells you in the Building/Compiling section that you have to configure some environment variables...

edit flag offensive delete link more

Comments

I followed the steps for Building/Compiling. I am still getting the error.

My SDK path is -- ~/naoqi/simulator-sdk-2.1.2.17-linux64 -- so i have added these envoirnment variables

AL_SIM_DIR = ~/naoqi/simulator-sdk-2.1.2.17-linux64

AL_DIR = ~/naoqi/simulator-sdk-2.1.2.17-linux64

Any Help?

saleem gravatar imagesaleem ( 2016-03-14 03:58:57 -0600 )edit

where did you add/export them? added to .bashrc? only in one terminal? Did you compile in the terminal where you set this? Also, does te path contain the include folder directly? Check out [this fiile] for where the paths should "end". Also, try replacing ~ with /home/saleem.

mgruhler gravatar imagemgruhler ( 2016-03-14 04:40:07 -0600 )edit

I have added them in .bashrc file. No path doesn't contain include folder directly. My AL_DIR= ~/naoqi/simulator-sdk-2.1.2.17-linux64 -- no include in the environment variables. Do i need to add include folder in AL_DIR?

saleem gravatar imagesaleem ( 2016-03-14 04:45:21 -0600 )edit

if you check out this file (now with the link hopefully working), you see it expects to have the include folder directly after your AL_SIM_DIR, this is ${AL_SIM_DIR}/include should exist.

mgruhler gravatar imagemgruhler ( 2016-03-14 05:18:32 -0600 )edit

Also (long shot, but just to be safe ;-) ). Did you source the .bashrc after adding the environment variables there?

mgruhler gravatar imagemgruhler ( 2016-03-14 05:19:32 -0600 )edit

I have hardcoded the include files in the headers. Now it has been compiled and motion and stiffness commands are working. Hoping that it will not crash for any other commands.

Thankss a lot mig for your help. Will get back to you for any other help. :)

saleem gravatar imagesaleem ( 2016-03-14 06:21:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-13 09:08:42 -0600

Seen: 244 times

Last updated: Mar 14 '16