Ask Your Question
1

no image received error in rviz

asked 2016-03-10 12:45:34 -0500

Ajith kumar gravatar image

Hi, I am using Ubuntu 12.04 with ROS hydro . Currently ,i am stuck with a error in rviz which states that " no image received" in status field under camera. I am using iball usb_cam. I tried all the camera drivers like gscam,uvc_camera,usb_cam . But , this error still exists . [Note: The image window does not produce any error. but camera window only produce this error .] Please give me any suggestions, Thank you

edit retag flag offensive close merge delete

Comments

Can you see the image with image_view?

joq gravatar imagejoq ( 2016-03-10 13:48:52 -0500 )edit

yes , i can see image with image_view

Ajith kumar gravatar imageAjith kumar ( 2016-03-10 19:48:56 -0500 )edit

I had the same problem. I was publishing the image and the camera_info correctly, but the image would still not show up. Solution: republishing my static tfs at 10 Hz, using tf instead of using tf2_ros. This solved the issue. I think that similar problems are common with rviz in ROS Indigo.

jespestana gravatar imagejespestana ( 2017-06-28 08:04:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-04-20 07:44:26 -0500

gimcuan gravatar image

Two days ago, i meet this problem too. And below is how i solved it :

1, using rosconsole to open rviz node debugging mode.

rosconsole set /rviz_1492690688381763966 ros.rviz.message_filter debug

rviz_1492690688381763966 was your rviz node's name

and it shown the messages came from your camera with the frame name was head_camera(i used [usb_cam](http://wiki.ros.org/usb_cam) driver)

2, modify map to head_camera in Fixed Frame field of rviz.

edit flag offensive delete link more

Comments

instead of changing the global frame, you could also provide tf data between the global frame and the camera frame (described here)

skoushan gravatar imageskoushan ( 2017-09-26 15:07:14 -0500 )edit
0

answered 2016-03-11 12:26:39 -0500

joq gravatar image

updated 2016-03-11 12:29:30 -0500

Is your camera driver publishing CameraInfo as well as Image data?

The rviz Camera display requires calibration information, while the Image display does not.

See: http://wiki.ros.org/rviz/DisplayTypes...

edit flag offensive delete link more

Comments

[head_camera] does not match name narrow_stereo in file /home/user/.ros/camera_info/head_camera.yaml.....yes usb_cam is publishing camera_info . I think the problem may be because of this error . I manually put the camera calibration file in .ros/camera_info folder .

Ajith kumar gravatar imageAjith kumar ( 2016-03-12 08:30:23 -0500 )edit

Most camera drivers publish a camera_info topic in parallel with an image_raw topic. A null calibration is sufficient for rviz, but none at all will cause the problem you reported.

joq gravatar imagejoq ( 2016-03-12 11:14:04 -0500 )edit

Resolved that name does not match error by renaming . But still "no image received" error esxists

Ajith kumar gravatar imageAjith kumar ( 2016-03-12 17:30:05 -0500 )edit

Maybe you need to edit your camera_info file so it matches the camera name.

joq gravatar imagejoq ( 2016-03-12 22:49:12 -0500 )edit

i edited and resolved that name error .My camera driver publishes camera_info .but still that "no image problem exists".

Ajith kumar gravatar imageAjith kumar ( 2016-03-14 07:27:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-10 12:45:34 -0500

Seen: 5,527 times

Last updated: Mar 11 '16