missing packets from vicon bridge

asked 2016-03-06 13:18:26 -0600

holmes.kirby gravatar image

updated 2016-03-08 07:17:47 -0600

I'm passing vicon data to a pixhawk for velocity estimation for autonomous flight. Frequently, there are gaps in the data from vicon bridge that causes the position and velocity estimates on the pixhawk to wander all over the place.

I can't figure out where the bottleneck in the system is. The gaps in the data can last up two a few seconds.

Has anyone else had trouble with gaps in the vicon data?

My Setup: I have a windows computer running the vicon tracker software. Both the vicon computer and my loptop are on the same private wireless network. I am running vicon_bridge on my laptop using the ClientPull stream mode. I'm running a repeater node on my laptop that is sending vicon information back over the wireless network to my odroid computer. The odroid computer is running the control/autonomy software and is passing vicon data/ desired attitude/ and throttle to the pixhawk.

I have tried bagging on both the odroid and the laptop and have not seen any difference in the consistency in the vicon stream. The same gaps in the vicon data and the repeated data are the same in the bag so I believe the problem is upstream of the repeater node.

edit retag flag offensive close merge delete

Comments

This is over a wireless link?

gvdhoorn gravatar imagegvdhoorn ( 2016-03-07 01:46:19 -0600 )edit

yes. its a private network. there isn't any other traffic

holmes.kirby gravatar imageholmes.kirby ( 2016-03-07 08:57:02 -0600 )edit

I'm not saying it is the cause of the issue you are seeing, but every wireless network will suffer from packet loss. Even if it is a private network, there will/can always be interference from other networks / microwaves etc. Can you tell us a bit more about your system setup?

gvdhoorn gravatar imagegvdhoorn ( 2016-03-08 03:07:08 -0600 )edit

Ive edited the question

holmes.kirby gravatar imageholmes.kirby ( 2016-03-08 07:08:05 -0600 )edit

You have a lot of wireless action going on. I'm not sure I understand you correctly, but are you saying that there is a wireless connection between the 'vicon computer' and your laptop? Have you tried with all-wired, and see whether that makes a difference?

gvdhoorn gravatar imagegvdhoorn ( 2016-03-10 03:17:13 -0600 )edit