Ask Your Question
1

Load ROS projects inside Eclipse

asked 2016-02-25 14:04:37 -0500

Randerson gravatar image

updated 2016-02-25 14:35:22 -0500

Hello all, I am trying quite a reasonable time to load a ros package as a project in Eclipse. Of course I am following the steps of section 2.2 Catkin-y approach from the tutorial IDEs but It is not working. I also checked the Catkin and eclipse answer. All the times that I tried to import a package as a Eclipse project I got No projects are found to import as show in the following screeshot: image description

I will appreciate any king of help or tip like: Should I reinstall eclipse, should I create a new catkin workspace, ...

Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2016-02-26 02:44:59 -0500

updated 2016-02-26 02:46:50 -0500

There are many things that you might be missing:

  • When doing catkin_make make sure that you have done catkin_make --force-cmake -G"Eclipse CDT4 - Unix Makefiles" otherwise the Eclipse configuration files are not going to be there ( I assume this is OK). To validate this, in your build/ folder there should be two files: .cproject and .project.

  • I assume you are following the IDEs tutorial exactly as they say (regarding how Eclipse should be installed). Specially, regarding how you launch Eclipse. In my case, I have a EclipseROS.desktop file in~/.local/share/applications/ that looks as follows:

[Desktop Entry]
Name=Eclipse 4
Type=Application
Exec=env SWT_GTK3=1 bash -i -c "/opt/eclipse/eclipse"
Terminal=false
Icon=/opt/eclipse/icon.xpm
Comment=Integrated Development Environment
NoDisplay=false
Categories=Development;IDE;
Name[en]=EclipseROS
Name[en_US]=EclipseROS

And my .bashrc constains source~/catkin_ws/devel/setup.bash`.

  • Finally, simply browse in your build/ folder, do not go down to the package folder, because is in build where the Eclipse configuration files .cproject and .project are generated (at least for catkin_make, for catkin tools a couple of files is generated for every package).
edit flag offensive delete link more

Comments

Thanks, everything was corrected but instead of browse in the build/ folder I was browsing in the packge folders. Naive mistake.

Randerson gravatar image Randerson  ( 2016-02-26 04:54:32 -0500 )edit
0

answered 2016-02-25 14:18:58 -0500

gvdhoorn gravatar image

It's only just visible in your screenshot, but I'm pretty sure the page you link to tells you to import things from the build space, not the src/ space?

edit flag offensive delete link more

Comments

I edited my question. :). I tried all directories.

Randerson gravatar image Randerson  ( 2016-02-25 14:30:14 -0500 )edit
1

Please edit your question to exactly list all the steps you took, especially those in the terminal.

gvdhoorn gravatar image gvdhoorn  ( 2016-02-25 15:00:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-25 14:04:37 -0500

Seen: 2,190 times

Last updated: Feb 26 '16