ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Couldn't find an AF_INET address for [hostname]

asked 2016-02-23 23:43:36 -0500

cros gravatar image

when Running ROS across multiple machines ,it can share master for two machines,but when run a node ,it appear something like Couldn't find an AF_INET address for [hostname],I don't know why. when I run a node in machine a,it pub a topic named "message",but I can't sub the "message" for a node from machine b,but when I use "rostopic list ",it has the topic named "message"

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2016-02-24 01:09:15 -0500

ahendrix gravatar image

Searching for your error message finds a few other users who have had the same problem and resolved it. Have you tried any of their solutions:

edit flag offensive delete link more

answered 2016-12-14 06:51:47 -0500

yucelokan gravatar image


I had same problem while ı am trying the upper link. I resolved, resolve is here.

open the .bashrc files and add this code.

You'll see those things like that:

export ROS_MASTER_URI=http://localhost (or something like that which is not your ip):11311
export ROS_HOSTNAME=(your machine name)

and you must change it like that:


change your ip adress.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-02-23 23:43:36 -0500

Seen: 6,264 times

Last updated: Feb 24 '16