Ask Your Question
0

PR2 simulation not working ROS Hydro

asked 2016-02-21 13:46:47 -0500

meep gravatar image

So I ran: roslaunch gazebo_ros empty_world.launch

to start Gazebo in an empty world. The gazebo window pops up but the terminal stops at this: gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://127.0.0.1:11345 Msg Publicized address: 10.0.0.9 Msg Connected to gazebo master @ http://127.0.0.1:11345 Msg Publicized address: 10.0.0.9

Even after waiting for awhile, the terminal seems to be stuck at this point and does not allow me to type any commands. I've tried redoing the command multiple but it keeps stopping at the same point.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-21 21:13:07 -0500

ahendrix gravatar image

roslaunch does not return control of the terminal until all of the nodes in the roslaunch file exit, and gazebo does not usually accept input from the command line.

In short, it sounds like gazebo is working.

Are you able to interact with the gazebo window that pops up? What else do you expect it do?

edit flag offensive delete link more

Comments

Yes thank you I figured it out. New to ros sorry.

meep gravatar image meep  ( 2016-02-21 22:04:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-21 13:46:47 -0500

Seen: 56 times

Last updated: Feb 21 '16