Ask Your Question
1

How to install eband_local_planner?

asked 2016-02-19 05:13:14 -0500

DanThe gravatar image

updated 2016-10-24 09:08:26 -0500

ngrennan gravatar image

Hi all,

I would appreciate it if someone can guide me on how to install eband_local_planner for use with move_base on Hydro because every approach that I have tried so far, has failed.

Thanks



I installed eband_local_planner by using the following commands:

rosws set eband_local_planner https://github.com/utexas-bwi/eband_local_planner --git
rosws eband_local_planner
roscd eband_local_planner
rosmake

Running the command rospack plugins --attrib=plugin nav_core shows eband_local_planner loaded as a plugin but the eband_local_planner is installed in /home/powerbot67/ros/eband_local_planner/elp_plugin.xml while the rest of the plugins are installed in /opt/ros/hydro/share. Could this be a problem?

powerbot67@powerbot67-desktop:~$ printenv | grep ROS
ROS_ROOT=/opt/ros/hydro/share/ros
ROS_PACKAGE_PATH=/home/powerbot67/ros/sbpl_lattice_planner:/home/powerbot67/ros/eband_local_planner:/home/powerbot67/hydro/sandbox:/opt/ros:/opt/ros/hydro/share:/opt/ros/hydro/stacks
ROS_MASTER_URI=http://localhost:11311
ROS_WORKSPACE=/home/powerbot67/ros
ROSLISP_PACKAGE_DIRECTORIES=
ROS_DISTRO=hydro
ROS_ETC_DIR=/opt/ros/hydro/etc/ros

I changed the move_base.launch file to use eband_local planner as follows:

<arg name="base_local_planner" default="eband_local_planner/EBandPlannerROS"/>

However, when I run move_base, I get the following error:

[FATAL] [1455878479.341080841]: Failed to create the eband_local_planner/EBandPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: Could not find library corresponding to plugin eband_local_planner/EBandPlannerROS. Make sure the plugin description XML file has the correct name of the library and that the library actually exists. [move_base-1] process has died [pid 5295, exit code 1, cmd /opt/ros/hydro/lib/move_base/move_base cmd_vel:=/RosAria/cmd_vel __name:=move_base __log:=/home/powerbot67/.ros/log/e58dae7e-d6f1-11e5-a32e-00026f87bbb1/move_base-1.log]. log file: /home/powerbot67/.ros/log/e58dae7e-d6f1-11e5-a32e-00026f87bbb1/move_base-1*.log

Also, running roswtf gives the following:

ERROR Not all paths in ROS_PACKAGE_PATH [/home/powerbot67/ros/sbpl_lattice_planner:/home/powerbot67/ros/eband_local_planner:/home/powerbot67/hydro/sandbox:/opt/ros:/opt/ros/hydro/share:/opt/ros/hydro/stacks] point to an existing directory: 
 * /home/powerbot67/ros/sbpl_lattice_planner

What should I do to solve this?

Thanks

edit retag flag offensive close merge delete

Comments

ros version?

Procópio gravatar imageProcópio ( 2016-02-19 07:32:28 -0500 )edit

ROS version is Hydro

DanThe gravatar imageDanThe ( 2016-02-19 08:11:21 -0500 )edit

it looks like eband_local_planner is a catkin package. Why are you trying to build it with rosmake?

ahendrix gravatar imageahendrix ( 2016-02-24 02:35:57 -0500 )edit

I am not sure when to use rosmake but your answer to my other question installed eband_local_planner successfully. Thanks

DanThe gravatar imageDanThe ( 2016-02-24 03:19:03 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-02-24 02:33:41 -0500

ahendrix gravatar image

eband_local_planner is marked as "released" on its wiki page. This means that you should be able to install it from debs with:

sudo apt-get install ros-hydro-eband-local-planner
edit flag offensive delete link more

Comments

Thank you!

DanThe gravatar imageDanThe ( 2016-02-24 03:13:06 -0500 )edit
0

answered 2016-02-24 02:35:37 -0500

yasagitov gravatar image

Are you passing base_local_planner parameter correctly? Try passing base_local_planner parameter inside node tag.

This is my launch file, and eband_local_planner is working properly.

<node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
  <rosparam file="$(find car_2dnav)/config/costmap_common_params.yaml" command="load" ns="global_costmap"/>
  <rosparam param="base_local_planner">eband_local_planner/EBandPlannerROS</rosparam>      
</node>
edit flag offensive delete link more

Comments

I am passing the parameter as follows below and I think that now it being launched correctly. The problem was with installing eband_local_planner correctly. However, thanks for your answer.

<arg name="base_local_planner" default="eband_local_planner/EBandPlannerROS"/>
DanThe gravatar imageDanThe ( 2016-02-24 03:22:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-19 05:13:14 -0500

Seen: 750 times

Last updated: Feb 24 '16