Ask Your Question
0

Modifying the Turtlebot Follower

asked 2016-02-10 09:39:20 -0500

bsuwirjo gravatar image

I am new to ROS and I am currently trying to figure out how to modify the built in follower demo. I modified the cpp file but can not figure out how to build the workspace. I have looked around for an answer but have not yet found one.

When I run catkin_make it returns

"The specified source space "/home/bsuwirjo/turtlebotCode/turtlebot_apps-indigo/src" does not exist".

When I try rosmake it returns

[ rosmake ] rosmake starting...
[ rosmake ] No package or stack specified. And current directory 'turtlebot_apps-indigo' is not a package name or stack name. [ rosmake ] Packages requested are: []
[ rosmake ] Logging to directory /home/bsuwirjo/.ros/rosmake/rosmake_output-20160204-175201
[ rosmake ] Expanded args [] to: []
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

Is it something I'm doing wrong regarding the commands?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-02-11 16:34:05 -0500

nampi gravatar image

I think you don't have "src" folder.

All packages are situated here:

/home/bsuwirjo/turtlebotCode/turtlebot_apps-indigo/src/turtlebot_apps/

For instance, path to the turtlebot_follower:

/home/bsuwirjo/turtlebotCode/turtlebot_apps-indigo/src/turtlebot_apps/turtlebot_follower

You run "catkin_make" here:

/home/bsuwirjo/turtlebotCode/turtlebot_apps-indigo/
edit flag offensive delete link more

Comments

I downloaded the turtlebot apps folder right off of github and it didn't come with the file structure you mentioned above. Would I have to create them manually? or create a new workspace and copy the turtlebot apps folder into the src directory.

bsuwirjo gravatar image bsuwirjo  ( 2016-02-14 19:42:14 -0500 )edit

Yes, you should create a workspace and copy turtlebot_apps folder into the src directory. ( http://wiki.ros.org/ROS/Tutorials/Cre... ).

nampi gravatar image nampi  ( 2016-02-15 08:37:40 -0500 )edit

I am now able to build it successfully,however my changes are not being processes. I modified follower.cpp in the src directory and when I catkin_make it is able to detect the changes. However when I run the follower after sourcing, it doesn't change anything. Do you know what the proble is?

bsuwirjo gravatar image bsuwirjo  ( 2016-03-03 14:06:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-02-10 09:39:20 -0500

Seen: 153 times

Last updated: Feb 11 '16