Ask Your Question
0

Ubuntu 14.04.LTS problem with ROS

asked 2016-02-01 12:53:06 -0500

btaher20 gravatar image

Problem with Ubuntu 64 bits 14.04.LTS After using " sudo apt-get update && sudo apt-get install ros-electric-desktop-full or only using :sudo apt-get install ros-electric-desktop-full " I get error this. E: Unable to correct problems, you have held broken packages.

I try to solve this problem by following these below command in Terminal: sudo apt-get upgrade sudo apt-get update sudo apt-get update --fix-missing

But still I get same Error in Ubuntu 14.04.LTS system. Could any body give any helpful tips to get rid of this problem.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
4

answered 2016-02-01 14:11:29 -0500

ahendrix gravatar image

ROS Electric is very old; it shouldn't be possible to install it on Ubuntu 14.04. Did you upgrade this computer from a previous version of Ubuntu?

On 14.04, the recommended ROS versions are Indigo and Jade.

It sounds like apt is in a bad state on your computer; some kind of package conflict. Sometimes sudo apt-get install -f can fix this automatically, but usually it requires some manual work. If you edit your question to include the full error message from apt, and some more information about how you got here, I can help you debug further.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-02-01 12:53:06 -0500

Seen: 97 times

Last updated: Feb 01 '16