Ask Your Question
0

Is it possible to install ROS on Linux ARM?

asked 2016-01-25 16:29:51 -0500

ErivaldoJunior gravatar image

Hi,

I am working with a Chinese embedded board called Mini210S from FriendlyARM. I wasn't able to install any version of Ubuntu on it. I can only run a so called Linux Qtopia with kernel 3.0.15. I didn't find any information about how I can install ROS on such a system.

Could anyone give some light on this? It is possible to install ROS on this system? I can use Android in this board, but I was unable to install roscpp_android in it. I am facing a lot of compiling errors. Maybe Linux is a better choice. Also, if I cannot install ROS on this board, what is the best option to a PC with ROS send data to it? For example, I want this board to have an User Interface and control stepper motors. There will be a Intel NUC to do the have calculation and the Intel NUC will send the data for this board.

Thank you very much for any response!

edit retag flag offensive close merge delete

Comments

Hi erivaldo I've the same problem but I can't boot from sd card because, my Chinese board hasn't it. It only has usb Ethernet and rs485 ports. How can I transfert new distro in it? Thanks for your answer. Ale

aqua1964 gravatar image aqua1964  ( 2016-12-01 14:05:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-01-25 19:59:38 -0500

ahendrix gravatar image

You can install ROS from source on many platforms; and it is generally possible to build ROS from source directly on the small ARM boards, although it can sometimes take 24 hours or more.

I'd recommend that you start with the ros_comm or robot variant of ROS, and don't attempt to build the vision, perception or visualization packages at first. This will help keep the dependencies to a minimum and decrease the build time.

If your board is running a very minimal or non-standard version of Linux, you may have difficulty satisfying the dependencies for ROS. Since your variant of linux isn't supported by rosdep, you'll have to resolve all of your dependencies by hand.

Overall, this is not a task that I'd recommend for your first experiment with ROS. If you are going to attempt it, go through the from-source install process on a standard Ubuntu machine first, to get a feel for how the process goes when it is working, before you attempt the installation on your ARM board.

edit flag offensive delete link more

Comments

Ahendrix, thank you! Do you know if it is possible to cross-compile ros? My ARM board doesn't have any build tool. I do everything from my main PC and then send the compiled files to this board.

ErivaldoJunior gravatar image ErivaldoJunior  ( 2016-01-25 20:25:37 -0500 )edit

The only cross-compile toolchain that I'm aware of is meta-ros: https://github.com/bmwcarit/meta-ros and http://wiki.ros.org/hydro/Installatio... ; but I believe these are based on already having an OpenEmbedded/Yocto image for your board, which you add ROS to.

ahendrix gravatar image ahendrix  ( 2016-01-25 21:47:43 -0500 )edit

Ok, I tried ROSJAVA with Android 4.0.3 and it worked. I believe this will be my workaround to use ROS in this chinese board. Thank you, ahendrix.

ErivaldoJunior gravatar image ErivaldoJunior  ( 2016-02-07 17:08:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-01-25 16:29:09 -0500

Seen: 1,727 times

Last updated: Jan 25 '16