Ask Your Question
0

ASUS Xtion Pro Live is not detected by openni_launch in ROS Indigo

asked 2016-01-18 08:15:23 -0500

vladimir_robofit gravatar image

updated 2016-01-19 08:34:57 -0500

Hello! When I plug-in ASUS Xtion Pro Live to my computer and run openni_launch I see following:

... logging to /home/vladimir/.ros/log/78148552-be96-11e5-ae5f-74d435f46c5e/roslaunch-vladimir-H97-D3H-2475.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://vladimir-H97-D3H:41432/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads: 4
 * /camera/depth_rectify_depth/interpolation: 0
 * /camera/depth_registered_rectify_depth/interpolation: 0
 * /camera/disparity_depth/max_range: 4.0
 * /camera/disparity_depth/min_range: 0.5
 * /camera/disparity_registered_hw/max_range: 4.0
 * /camera/disparity_registered_hw/min_range: 0.5
 * /camera/disparity_registered_sw/max_range: 4.0
 * /camera/disparity_registered_sw/min_range: 0.5
 * /camera/driver/depth_camera_info_url: 
 * /camera/driver/depth_frame_id: camera_depth_opti...
 * /camera/driver/depth_registration: False
 * /camera/driver/device_id: #1
 * /camera/driver/rgb_camera_info_url: 
 * /camera/driver/rgb_frame_id: camera_rgb_optica...
 * /rosdistro: indigo
 * /rosversion: 1.11.16

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    debayer (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_hw_metric_rect (nodelet/nodelet)
    depth_registered_metric (nodelet/nodelet)
    depth_registered_rectify_depth (nodelet/nodelet)
    depth_registered_sw_metric_rect (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_registered_hw (nodelet/nodelet)
    disparity_registered_sw (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_hw_registered (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_ir (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /
camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [2493]
process[camera/driver-2]: started with pid [2494]
process[camera/debayer-3]: started with pid [2495]
process[camera/rectify_mono-4]: started with pid [2496]
process[camera/rectify_color-5]: started with pid [2497]
process[camera/rectify_ir-6]: started with pid [2498]
process[camera/depth_rectify_depth-7]: started with pid [2499]
process[camera/depth_metric_rect-8]: started with pid [2500]
process[camera/depth_metric-9]: started with pid [2501]
process[camera/depth_points-10]: started with pid [2502]
process[camera/register_depth_rgb-11]: started with pid [2503]
process[camera/points_xyzrgb_sw_registered-12]: started with pid [2504]
process[camera/depth_registered_sw_metric_rect-13]: started with pid [2505]
process[camera/depth_registered_rectify_depth-14]: started with pid [2506]
process[camera/points_xyzrgb_hw_registered-15]: started with pid [2507]
process[camera/depth_registered_hw_metric_rect-16]: started with pid [2508]
process[camera/depth_registered_metric-17]: started with pid [2509]
process[camera/disparity_depth-18]: started with pid [2510]
process[camera/disparity_registered_sw-19]: started with pid [2511]
process[camera/disparity_registered_hw-20]: started with pid [2512]
process[camera_base_link-21]: started with pid [2602]
process[camera_base_link1-22]: started with pid [2626]
process[camera_base_link2-23]: started with pid [2631]
process[camera_base_link3-24]: started with pid [2634]
[ INFO] [1453198954.973950381]: Initializing nodelet with 4 worker threads.
[ INFO] [1453198956.744221872]: No devices connected.... waiting for devices to be connected

The lsusb command listed ASUS sensor. I have Ubuntu 14.04 and ROS Indigo on my computer. Did anybody faced into such a problem?

edit retag flag offensive close merge delete

Comments

Please post the full terminal output, there is not enough information in what you pasted.

Javier V. Gómez gravatar image Javier V. Gómez  ( 2016-01-18 12:13:36 -0500 )edit

I hope anyone saw this problem. openni_launch should support Xtion PRO.

vladimir_robofit gravatar image vladimir_robofit  ( 2016-01-20 07:18:11 -0500 )edit

Check out this answer for tips on how I get the ASUS working. Specifically, check out the permissions and the editing of /etc/openni/GlobalDefaults.ini

jarvisschultz gravatar image jarvisschultz  ( 2016-01-25 07:55:36 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2016-01-25 06:03:34 -0500

YingHua gravatar image

Would you post your log and steps? I don't know how to help you with not enough information...

But I make some note about xtion with ROS in my blog but in Chinese. (click me to blog)

For asus xtion, you need to install openni2.

sudo apt-get install ros-indigo-openni2-camera ros-indigo-openni2-launch

and then do these steps to show image

roscore

roslaunch  openni2_launch  openni2.launch

rosrun rviz rviz

you may meet some error when rviz open. Just change the "fixed frame" can fix it.

edit flag offensive delete link more
0

answered 2016-01-25 06:08:39 -0500

Akif gravatar image

There may be a permission problem, so you can check device permissions.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-18 08:15:23 -0500

Seen: 702 times

Last updated: Jan 25 '16