Ask Your Question
0

Error when crawling with permissions problems

asked 2016-01-14 14:22:01 -0500

mcamp gravatar image

updated 2016-01-15 08:53:51 -0500

Hi all, I have a ros package that I want to access via roscd using autocompletion. But, for some weird configuration of our lab, I don't have permissions to see the files of a directory, thought I can access to one folder.

Example, I have my packages in:

/home/robot/rych/catking_ws/src

And I have no problem accessing or crawling there, but I don't have permissions in the folder:

/home/robot

So I get the error (warning actually):

Warning: error while crawling /home/robot: boost::filesystem::directory_iterator::construct: Permission denied: "/home/robot"

And this is really annoying, there is a way to disable this Warning? Or even better, there is a way to tell ros to not crawl into this specific folder? (allowing to crawl inside the package folder only)

Edit: I add the content of CMAKE_PREFIX_PATH and ROS_PACKAGE_PATH

CMAKE_PREFIX_PATH = /home/robot/rych/catkin_ws/devel:/home/robot/rych/PhaROS-ws/devel:/opt/ros/indigo

ROS_PACKAGE_PATH = /home/robot/rych/catkin_ws/src:/home/robot/rych/PhaROS-ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks
edit retag flag offensive close merge delete

Comments

What do you have your CMAKE_PREFIX_PATH and your ROS_PACKAGE_PATH environment variables set to? You might be able to adjust those to control the package search crawing behavior.

ahendrix gravatar imageahendrix ( 2016-01-14 15:49:46 -0500 )edit

I edited the question to show the content of both variables, can you see how to solve this with that information?

mcamp gravatar imagemcamp ( 2016-01-15 08:54:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-01-15 11:48:10 -0500

ahendrix gravatar image

The tab-completion for roscd eventually calls rospack; and that startup for rospack tries to query if the current directory is within a ROS package or not, by walking up from the current directory to /, looking for a package.xml.

It looks like this is a bug in rospack, and I don't see a good way to suppress it without modifying rospack. You should file an issue on the rospack issue tracker.

edit flag offensive delete link more

Comments

I see, thanks for that I will file this issue then

mcamp gravatar imagemcamp ( 2016-01-15 12:38:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-01-14 14:22:01 -0500

Seen: 586 times

Last updated: Jan 15 '16