ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

robot_localization can't locate node - jade upgrade

asked 2016-01-09 06:24:08 -0500 gravatar image

updated 2016-01-09 07:02:11 -0500

Akif gravatar image

Hi I have recently upgraded from indigo to jade, and installed (in ubuntu) the jade robot_localization package via apt.

When I do

roslaunch robot_localization  ekf_template.launch

I get

ERROR: cannot launch node of type [robot_localization/ekf_localization_node]: can't locate node [ekf_localization_node] in package [robot_localization]

or if I do

rosrun robot_localization ekf_localization_node

I get

[rosrun] Couldn't find executable named ekf_localization_node below /opt/ros/jade/share/robot_localization

I can see the package is installed, calization launch$ ls /opt/ros/jade/share/robot_localization/ cmake launch LICENSE package.xml srv

and it shows in rospack list.

Any ideas?

edit retag flag offensive close merge delete


I can also see the executable, /opt/ros/jade/lib/robot_localization/ekf_localization_node

which if I run directly from the command line, creates an odom/filtered topic. So looks like the node is installed but something is not set up correctly to know where it is? gravatar image  ( 2016-01-09 06:27:03 -0500 )edit

Interesting. Have you tried rospack profile? It sounds like something with your environment. Did you just upgrade to jade, and if so, did you source /opt/ros/jade/setup.bash?

Tom Moore gravatar image Tom Moore  ( 2016-02-05 08:20:03 -0500 )edit

Is this still a problem, or can this be closed?

Tom Moore gravatar image Tom Moore  ( 2017-07-20 04:14:48 -0500 )edit

I Got the same error. I'm using indigo distribution. I did "source devel/setup.bash" but the same error occurred when typing "roslaunch robot_localization ekf_template.launch". Please HELP

ZanaZak gravatar image ZanaZak  ( 2017-10-31 11:06:26 -0500 )edit

Hi I am facing the same issue and cannot find a way to solve it. Can I ask you have you found a way to solve this problem? I am using kinetic. Many thanks in advance.

dylanzhang gravatar image dylanzhang  ( 2017-12-20 11:06:22 -0500 )edit

Any reason why you are running that template? It's just meant to be used as an example. Running it won't do anything. Jade is EOL, but Kinetic is definitely installing those files.

Tom Moore gravatar image Tom Moore  ( 2018-01-11 03:18:27 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-01-11 03:19:15 -0500

Tom Moore gravatar image

It sounds like you have something wrong with your workspaces in general. Try source /opt/ros/kinetic/setup.bash, then run your command. If it works, then your workspace overlay is causing trouble.

edit flag offensive delete link more


How to fix this? Because I can access roslaunch robot_localization ekf_template.launch, but which will fail because it is not able to find ekf_localization_node.

I just installed ekf_localizaiton with: sudo apt-get install ros-kinetic-robot-localization and want to be able to access it in my current workspace.

seth gravatar image seth  ( 2019-06-12 09:26:58 -0500 )edit

What happens if you follow the steps in my answer? source /opt/ros/kinetic/setup.bash, then roslaunch robot_localization ekf_template.launch. Does it work? If so, then you need to catkin clean your workspace, source /opt/ros/kinetic/setup.bash, catkin build your workspace, then source your workspace devel/setup.bash file.

Tom Moore gravatar image Tom Moore  ( 2019-06-13 02:10:53 -0500 )edit

Yes with your answer I see 4 nodes to run: robot_localization_listener_node, navsat_tranform_node, ukf_localization_node and ekf_locallization_node. But otherwise I only see the first 2. After catkin clean I can still only see 2 out of the 4 existing nodes

seth gravatar image seth  ( 2019-06-13 04:19:30 -0500 )edit

Maybe I do not understand it correctly, since catkin_make clean did not work for me. However creating a new workspace and putting my packages in this new workspace fixed my problems. Thnx for the help =D

seth gravatar image seth  ( 2019-06-21 08:29:06 -0500 )edit

Question Tools

1 follower


Asked: 2016-01-09 06:24:08 -0500

Seen: 2,218 times

Last updated: Jan 09 '16