Ask Your Question
0

ekf odom and compass robot_localization

asked 2015-07-14 11:51:04 -0500

Porti77 gravatar image

updated 2015-07-27 03:14:01 -0500

Hi! I have a compass sensor and a odom sensor, this start in the position 0,0,0. The compass it's in the correct position but when i echo the odometry filtered It is delaying it will respect the GPS signal.

Any answer?

EDIT 1: This is a rosbag with the sensor topics https://www.dropbox.com/s/6kwbd1yaxix... This is a tree graph, nodes graph and rviz capture. image description image description

Red color /odometry/filtered and green color position/GPS image description image description

The position GPS is in absolute coordinates. The ekf launch is this, with the base link compass transformation:

<!-- EKF -->
<launch>

<node pkg="tf" type="static_transform_publisher" name="link1_broadcaster" args="0.0 0.0 0.0 0.0 0.0
0.0 1.0 base_link compass 20" />

<node pkg="robot_localization" type="ekf_localization_node" name="ekf_localization" clear_params="true">
  <param name="frequency" value="30"/>  
  <param name="sensor_timeout" value="0.1"/>  
  <param name="two_d_mode" value="true"/>

  <param name="map_frame" value="map"/>
  <param name="odom_frame" value="odom"/>
  <param name="base_link_frame" value="base_link"/>
  <param name="world_frame" value="odom"/>

  <param name="odom0" value="position/gps"/>
  <param name="imu0" value="compass/data"/> 


  <rosparam param="odom0_config">[true,  true,  false, 
                                  false, false, false, 
                                  false, false, false, 
                                  false, false, false,
                                  false, false, false]</rosparam>

  <rosparam param="imu0_config">[false, false, false, 
                                 false, false, true, 
                                 false, false, false, 
                                 false, false, false,
                                 false, false, false]</rosparam>

  <param name="odom0_differential" value="false"/>
  <param name="imu0_differential" value="false"/>

  <param name="imu0_remove_gravitational_acceleration" value="true"/>

  <param name="print_diagnostics" value="false"/>

  <!-- ======== ADVANCED PARAMETERS ======== -->

  <param name="odom0_queue_size" value="2"/>
  <param name="imu0_queue_size" value="10"/>

  <param name="debug"           value="false"/>
  <param name="debug_out_file"  value="/home/tmoore/Desktop/debug_ekf_localization.txt"/>

  <rosparam param="process_noise_covariance">[0.05, 0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.05, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.06, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.03, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.03, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.0, 0.06, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.025, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0,
                                              0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.025, 0.0, 0.0, 0.0, 0 ...
(more)
edit retag flag offensive close merge delete

Comments

Sorry, to clarify: you have wheel encoder odometry, a magnetometer, and a GPS? Are you using navsat_transform_node? Perhaps you can give me some more information about your setup.

Tom Moore gravatar imageTom Moore ( 2015-07-14 18:05:14 -0500 )edit
1

@Porti77 Better post the solution you found as an answer and mark it as an answer so that others can tell the question is solved.

130s gravatar image130s ( 2015-07-15 12:21:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-27 03:15:48 -0500

Porti77 gravatar image

updated 2015-07-27 03:16:02 -0500

Hi!! I already solved my problem , the error was that i wasnt including the time stamp in the topics of sensors and these become crazy the filter, now the system is working well!! Regards

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-14 11:51:04 -0500

Seen: 454 times

Last updated: Jul 27 '15