ROS Keyserver Down?

asked 2016-01-08 12:54:32 -0500

jeddy gravatar image

I've just installed ROS Indigo on a brand new installation of Ubuntu 14.04 per the instructions on the wiki. Unfortunately, I ran into trouble setting up my keys.

Every time that I ran

sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116

I got the following output:

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.pmoKA9JVGs --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116
gpg: requesting key B01FA116 from hkp server pool.sks-keyservers.net
?: pool.sks-keyservers.net: Network is unreachable
gpgkeys: HTTP fetch error 7: couldn't connect: Network is unreachable
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Is the keyserver down? If so, will it come back up? Googling for help, I've found several other questions describing experiences similar to my own. I was able to get the key by running the following command:

wget https://raw.githubusercontent.com/ros/rosdistro/master/ros.key -O - | sudo apt-key add -

After that, the installation process proceeded smoothly, and ROS is running just fine. I'm also able to ping both the keyserver site and packages.ros.org .

That being said, I think this begs the question of whether the installation instructions are incorrect/out-of-date/incomplete. Does someone--it's okay if it's me--need to make an update to the wiki, or is this problem actually a transient one (and thus might not warrant a change to the official instructions)? The only reason I ask is that I've been getting this error for several consecutive days now and others seem to have had this problem multiple times in the past. I'd like to help others avoid this little hiccup if possible.

Thanks in advance!

edit retag flag offensive close merge delete

Comments

If there is a problem, it's most likely with the key servers themselves. This is not infrastructure under control of the OSRF, it could well be that there are (transient) issues with them. As this is a pool, trying multiple times should eventually lead to a working one.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-09 11:02:59 -0500 )edit

Also: see sks-keyservers.net/status page for server status.

If this remains an issue, it might make sense to provide some alternatives though, as you write.

gvdhoorn gravatar imagegvdhoorn ( 2016-01-09 11:09:32 -0500 )edit

I am too facing the same problem. I am behind the proxy and unable to ping archive.ubuntu.com

sumant gravatar imagesumant ( 2016-09-02 02:21:01 -0500 )edit
gvdhoorn gravatar imagegvdhoorn ( 2016-09-02 02:37:57 -0500 )edit

Now its working , which may be because of proxy issue. going for alternate will also work.

sumant gravatar imagesumant ( 2016-09-03 08:58:15 -0500 )edit