Ask Your Question
0

Hello. I have been trying to install ros in debian jessie and I remain unsuccessful. I am not able to run the "sudo -E apt-key adv --keyserver hkp://pool.sks-keyservers.net:80 --recv-key 0xB01FA116". Can you please help me ?

asked 2015-12-18 05:17:30 -0500

mechatron gravatar image

It gives me an error "Host not found" when I run it. I also tried running the command without the port number but to no vain. In one post I read that it would help to rerun the command after sometime. But it has been 2 days and I am nowhere able to run this command. Can you please help me ? Is there a workaround for this problem ? Thank you

edit retag flag offensive close merge delete

Comments

2

Can you ping pool.sks-keyservers.net? On my system it resolves to 208.89.139.251. If all else fails, you could use that IP instead of the hostname and see if that works. But it would be a work around, and points to some issue with your DNS.

gvdhoorn gravatar image gvdhoorn  ( 2015-12-18 10:42:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-18 14:17:56 -0500

mechatron gravatar image

updated 2015-12-18 14:19:58 -0500

That was a brilliant suggestion. Thanks a lot. It worked :)

So as suggested in comments, I did ping "pool.sks-keyservers.net". I got the IP address from the command and used it in the command as follows "sudo -E apt-key adv --keyserver 1xx.2xx.1.8 --recv-key 0xB01FA116".

Hope this helps anyone who has similar issues

Cheers

edit flag offensive delete link more

Comments

I would really call this a work-around. The apt-key utility not being able to resolve that hostname to an IP seems to point to some issue with either your DNS or the way apt-key interacts with it. I only asked you to ping it so we could at least rule out a general DNS failure,

gvdhoorn gravatar image gvdhoorn  ( 2015-12-21 05:15:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-12-18 05:17:30 -0500

Seen: 104 times

Last updated: Dec 18 '15