Ask Your Question
0

GMAPPING: How to mark 'out of range' laserscan as free-space

asked 2015-12-17 04:33:54 -0500

Alex1209 gravatar image

I'm using a SICK TIM 300 Laserscanner with the gmapping node to create a Map. But whenever the Laserscanner can not see an obstacle at a certain angle (because the obstacles are out of range), gmapping marks these areas as 'unknown'. But the Laserscanner not seeing anything at a certain angle, means there is no obstacle within the measuring-range (in my case: 4m). As a result gmapping should mark these areas as free.

How can I solve this problem?

I'm using Ubuntu 12.04 with ROS hydro. The Laserscanner marks these 'out-of-range'-areas as 'distance = 0m', the header from the /scan - message tells that the minimum distance is 0.05m.

Thanks for your help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-12-17 05:25:00 -0500

If you take a look at the gmapping page there're two parameters called maxUrange and maxRange. I quote: "If regions with no obstacles within the range of the sensor should appear as free space in the map, set maxUrange < maximum range of the real sensor <= maxRange".

So, if you want that region appears as free space, you have to set your maxUrange under the maximum range of the real sensor (which is the maxRangeparameter).

edit flag offensive delete link more

Comments

Thank you very much :D It's that easy. Now the map looks way better.

Alex1209 gravatar imageAlex1209 ( 2015-12-17 16:01:01 -0500 )edit

what is the unit of maxUrange and max range?

aarontan gravatar imageaarontan ( 2018-05-19 14:51:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-12-17 04:33:54 -0500

Seen: 723 times

Last updated: Dec 17 '15