Ask Your Question
0

Hide robot model in rviz

asked 2015-12-09 15:06:06 -0600

Ali250 gravatar image

I've used moveit setup assistant to generate the config files for the Nao robot. I'm then using rviz to visualize joint trajectories. The problem is that the trajectories show up semi-transparent whereas the static robot model that's present when I launch rviz is solid. This makes visualizing a bit annoying.

Is there any way to hide the solid model that shows up when I launch rviz?

edit retag flag offensive close merge delete

Comments

1

I think you must to test the options at left hand on Rviz. There you can fix what you want to see in your environment, and saving the configuration.

Fredylucas gravatar imageFredylucas ( 2015-12-09 18:24:20 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-12-09 18:34:53 -0600

mkhansen gravatar image

updated 2015-12-09 18:46:50 -0600

You should be able to simply un-check the 'Visual Enabled' check box under your 'RobotModel' status in the 'Displays' pane on the left side of the screen. See this link for more info:http://wiki.ros.org/rviz/DisplayTypes/RobotModel

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-09 15:06:06 -0600

Seen: 92 times

Last updated: Dec 09 '15