ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

how to launch pr2 simulation in jade

asked 2015-11-30 08:11:32 -0500

pitpet gravatar image

I followed the tutorial of pr2 simulation:

roslaunch gazebo_ros empty_world.launch

this command is fine, the gazebo window shows an empty world. while run the following command :

roslaunch pr2_gazebo pr2.launch

an error occurs:

[pr2.launch] is neither a launch file in package [pr2_gazebo] nor is [pr2_gazebo] a launch file name

There's no package named 'pr2_gazebo' in jade, I tried to find it with apt-get:

aptitude search pr2

there are 6 packages in jade related to pr2:


none of them contains pr2.launch. So, how can I run simulation for pr2 in jade?

edit retag flag offensive close merge delete


why I can't see this question in the ask list? and it says 'this post is awaiting moderation', what does that mean? what do I need to do to moderate it?

pitpet gravatar image pitpet  ( 2015-11-30 08:03:55 -0500 )edit

@pitpet: as the question was posted by a new account, it has t go through the moderation process, which basically means that one of the ROS Answers moderators needs to ensure that you are not a bot that is trying to spam. I just did that, so your question should now show up on the main site.

gvdhoorn gravatar image gvdhoorn  ( 2015-11-30 09:03:18 -0500 )edit

ok, thanks

pitpet gravatar image pitpet  ( 2015-12-02 21:43:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-12-04 08:02:27 -0500

gvdhoorn gravatar image

Looking at debbuild/jade.html?q=pr2 and the pr2_gazebo wiki page, it would seem the pr2_gazebo package (and many others in fact) have not yet been released for ROS Jade. The newest versions are for Indigo.

You might be able to build them from sources in a catkin workspace.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-11-30 07:59:11 -0500

Seen: 989 times

Last updated: Dec 04 '15