Ask Your Question
0

[ERROR] IMU_node (help-me)

asked 2015-11-26 11:47:51 -0500

rafael_palma gravatar image

updated 2015-11-30 09:47:14 -0500

gvdhoorn gravatar image

Hello guys, I'm trying to use the imu_node , but by following the tutorial contained herein : http://wiki.ros.org/microstrain_3dmgx... , I encounter the following message:

[ ERROR] [ 1448558982.111227055 ] : Device / dev / ttyUSB0 is already locked . Try ' lsof | grep / dev / ttyUSB0 'to find other processes que currently have the port open . (in microstrain_3dmgx2_imu :: IMU : OpenPort ) You may find further details at http://www.ros.org/wiki/microstrain_3dmgx2_imu/Troubleshooting .

I've tried several exits , but it still fails. Algem could give me some way ?

Inertia-Link and 3DM-GX2 sensor.


Edit: Hello, thank you for responding. I've tried you-plugging the device. How could I kill a process? Is there any way to choose the input the turns on? That would solve?

when I do lsof|grep /dev/ttyUSB0, i received this information:

rafael@rafael-pc:~$ lsof|grep /dev/ttyUSB0
imu_node  21051           rafael    9uW     CHR              188,0      0t0  5244268 /dev/ttyUSB0
imu_node  21051 21060     rafael    9uW     CHR              188,0      0t0  5244268 /dev/ttyUSB0
imu_node  21051 21061     rafael    9uW     CHR              188,0      0t0  5244268 /dev/ttyUSB0
imu_node  21051 21062     rafael    9uW     CHR              188,0      0t0  5244268 /dev/ttyUSB0
imu_node  21051 21067     rafael    9uW     CHR              188,0      0t0  5244268 /dev/ttyUSB0

Thank you very much!

UPDATE:

Now I see that there are no processes using the port. The other possible reason is given: "This sometimes happens if you are not connected to an IMU". The USB Base Station is connected to the USB port and the sensor is also connected (but not in pc), have to do something else? I do not understand the error, since there are not processes trying to use the port. Thank you!

asdfasdf

edit retag flag offensive close merge delete

Comments

Rafael: please don't post answers when you only want to post an update. Edit your original question with that new information. Use the edit link/button for that.

gvdhoorn gravatar image gvdhoorn  ( 2015-11-30 09:48:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-27 01:41:16 -0500

Akif gravatar image

updated 2015-11-30 04:46:32 -0500

The error tells that /dev/ttyUSB0 device is used by some other processes. As it suggests, you can check the output of lsof | grep /dev/ttyUSB0 command to see any relevant processes and kill them before running this.

You may also try re-plugging the device.

UPDATE:

You can run rosnode kill imu_node to kill your previous node if it hangs. If you do not succeed with this check this topic.

edit flag offensive delete link more

Comments

Hello, thank you for responding. I answered your comment just above, could help me??

rafael_palma gravatar image rafael_palma  ( 2015-11-29 18:13:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-11-26 11:47:51 -0500

Seen: 223 times

Last updated: Nov 30 '15