Error when creating MoveIt Package for an Industrial Robot

asked 2015-11-26 07:39:48 -0600

jcgarciaca gravatar image

Hello, I try to create my MoveIt Package for an industrial Robot with using roslaunch moveit_setup_assistant setup_assistant.launch. Nevertheless, when I load the URDF file, the next error appears.

process[moveit_setup_assistant-2]: started with pid [4917]
[rospack] Error: no package given
[librospack]: error while executing command
[ INFO] [1448512656.001013398]: Loaded motoman_mh6full robot model.
[ INFO] [1448512656.001170464]: Setting Param Server with Robot Description
[ INFO] [1448512656.009861701]: Robot semantic model successfully loaded.
[ INFO] [1448512656.009944719]: Setting Param Server with Robot Semantic Description
[ INFO] [1448512656.039318561]: Loading robot model 'motoman_mh6full'...
[ INFO] [1448512656.040011320]: No root joint specified. Assuming fixed joint
[ INFO] [1448512656.419745270]: Stereo is NOT SUPPORTED
[ INFO] [1448512656.419875001]: OpenGl version: 3 (GLSL 1.3).
/opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant: symbol lookup error: /opt/ros/indigo/lib/libmoveit_setup_assistant_widgets.so: undefined symbol: _ZN4rviz20VisualizationManagerC1EPNS_11RenderPanelEPNS_22WindowManagerInterfaceE
================================================================================REQUIRED process [moveit_setup_assistant-2] has died!
process has died [pid 4917, exit code 127, cmd /opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/juliocesar/.ros/log/5cfbbb10-93f7-11e5-b742-dca97142d524/moveit_setup_assistant-2.log].
log file: /home/juliocesar/.ros/log/5cfbbb10-93f7-11e5-b742-dca97142d524/moveit_setup_assistant-2*.log
Initiating shutdown!
================================================================================
[moveit_setup_assistant-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

If I check the URDF, it shows:

robot name is: motoman_mh6full
---------- Successfully Parsed XML ---------------
root Link: base_rail_link has 2 child(ren)
    child(1):  base_link_b1
        child(1):  arm_base_link
            child(1):  arm_link_s
                child(1):  arm_link_l
                    child(1):  arm_link_u
                        child(1):  arm_link_r
                            child(1):  arm_link_b
                                child(1):  arm_link_t
                                    child(1):  arm_link_tool0
    child(2):  station_station_link
        child(1):  station_link_s1

And the instruction roslaunch urdf_tutorial display.launch model:=mh6full.urdf gui:=True shows my model properly.

How can I fix it? Thank you.

edit retag flag offensive close merge delete

Comments

This looks like a problem in the Setup Assistant, not in your model, or in the tutorial. Can you tell us how you installed ROS (apt-get, from-source), which version of ROS this is, OS, version of OS, what kind of hardware, etc?

gvdhoorn gravatar image gvdhoorn  ( 2015-11-26 08:32:43 -0600 )edit

Hello, thanks for your answer. I installed ros with apt-get, I have ROS Indigo on Ubuntu 10.04.1 (32 bits - i686). And previosly I created a MoveIt Package for my own URDF without any problem, but now it doesn't work.

jcgarciaca gravatar image jcgarciaca  ( 2015-11-26 09:13:08 -0600 )edit

I'll assume you mean Ubuntu 14.04.1 (Trusty).

In any case: I've not seen other reports where Setup Assistant suddenly developed this issue, so I guess it's something local to your installation. Can you do a sudo apt-get update && sudo apt-get dist-upgrade? Pay attention to what it wants to do.

gvdhoorn gravatar image gvdhoorn  ( 2015-11-28 09:30:05 -0600 )edit

Thanks for all your help. I tried with the suggested instruction but didn't work. Then I removed MoveIt and installed it again and it's OK. Thank you.

jcgarciaca gravatar image jcgarciaca  ( 2015-12-01 07:26:10 -0600 )edit

With removing and then reinstalling you have essentially done the same thing. But good to hear it works now.

gvdhoorn gravatar image gvdhoorn  ( 2015-12-01 07:42:15 -0600 )edit