Ask Your Question
0

following tutorial for publisher and subscriber : missing liblog4cxx.so

asked 2015-11-24 15:57:21 -0500

JonasV gravatar image

When trying to catkin_make the catkin_ws folder i get the following output:

####
#### Running command: "make cmake_check_build_system" in "/home/testros/catkin_ws/build"
####
####
#### Running command: "make -j4 -l4" in "/home/testros/catkin_ws/build"
####
[  0%] Built target std_msgs_generate_messages_eus
[  0%] Built target std_msgs_generate_messages_py
[  0%] Built target std_msgs_generate_messages_lisp
[  0%] Built target std_msgs_generate_messages_cpp
[  0%] Built target _beginner_tutorials_generate_messages_check_deps_Num
[  0%] Built target _beginner_tutorials_generate_messages_check_deps_AddTwoInts
[ 30%] [ 46%] Built target beginner_tutorials_generate_messages_py
[ 61%] Built target beginner_tutorials_generate_messages_lisp
Built target beginner_tutorials_generate_messages_cpp
[ 84%] Built target beginner_tutorials_generate_messages_eus
make[2]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/liblog4cxx.so', needed by '/home/testros/catkin_ws/devel/lib/beginner_tutorials/listener'.  Stop.
make[2]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/liblog4cxx.so', needed by '/home/testros/catkin_ws/devel/lib/beginner_tutorials/talker'.  Stop.
CMakeFiles/Makefile2:721: recipe for target 'beginner_tutorials/CMakeFiles/listener.dir/all' failed
make[1]: *** [beginner_tutorials/CMakeFiles/listener.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
CMakeFiles/Makefile2:1128: recipe for target 'beginner_tutorials/CMakeFiles/talker.dir/all' failed
make[1]: *** [beginner_tutorials/CMakeFiles/talker.dir/all] Error 2
[ 84%] Built target beginner_tutorials_generate_messages
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
Invoking "make -j4 -l4" failed

Is it a problem with my ROS installation? I tried rosdep install liblog4cxx, but it did not find anything.

edit retag flag offensive close merge delete

Comments

Did this ever get solved? I'm having the same problem. Thanks.

mmiles19 gravatar image mmiles19  ( 2016-03-28 01:27:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-24 19:29:29 -0500

William gravatar image

rosdep install liblog4cxx is not the correct syntax (confusing I know). You'd need to do rosdep install beginner_tutorials (this only works if beginner_tutorials is on your ROS_PACKAGE_PATH) or rosdep install --from-paths /home/testros/catkin_ws/src to install all dependencies for all packages in your catkin workspace.

edit flag offensive delete link more

Comments

Doesn't seem to change anything. I tried:

rosdep check beginner_tutorials: All system dependencies have been satisified
rosdep resolve log4cxx: #apt liblog4cxx10-dev
rosdep what-needs log4cxx: rosconsole
rosdep where-defined log4cxx: raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml
JonasV gravatar image JonasV  ( 2015-11-25 12:57:55 -0500 )edit

I don't know then, it seems something is suggesting the file /usr/lib/x86_64-linux-gnu/liblog4cxx.so should be linked against, but it doesn't seem to exist. You can check to see if that file exists and if it does not look at the files installed by the liblog4cxx10-dev deb.

William gravatar image William  ( 2015-11-26 04:02:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-24 15:57:21 -0500

Seen: 656 times

Last updated: Nov 24 '15