Is it possible to connect ROS with a virtual NAO?

asked 2015-11-19 03:32:45 -0600

RalfM gravatar image

updated 2015-11-20 02:44:29 -0600

The installation of ROS for usage with or on a NAO robot is recommended for NAOqi version 2.1.2. Unfortunately our (university) NAO works with NAOqi 1.14. However I used the installation manual and tried it, but the step(bridge connection) failed. So my question is: 1." Is it possible to connect ROS with a virtual NAO? A virtual NAO will be created if i start choregraph software." I tried it but no success. Maybe I forgot something.... 2. "Is there any possibility to use the manual with NAOqi 1.14?

here a my command and logs:

osboxes@osboxes:~$ rosrun naoqi_driver naoqi_driver_node --qi-url=tcp:// --roscore_ip --network_interface wlan0 going to add: /home/osboxes/catkin_ws/devel [W] 4464 qi.path.sdklayout: No Application was created, trying to deduce paths going to add: /opt/ros/indigo Receiving information about robot model [W] 4464 qimessaging.remoteobject: Return signature might be incorrect depending on the value, from m to s terminate called after throwing an instance of 'qi::FutureUserException' what(): ALMemory::getData Data not found RobotConfig/Body/Type Aborted (core dumped)

best regards Ralf

edit retag flag offensive close merge delete