ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

how to change the RPLIDAR frequency?

asked 2015-11-16 23:59:32 -0600

Asim Arif gravatar image

updated 2015-11-18 20:14:53 -0600

hi i want to know how to change the LIDAR's frequency from 5.5 Hz to say 10 Hz . I know that it involves changing the PWM singal to the motors to increase its scan rate but how do i do it ? like where is the setting in the source code ?

thanks in advance

edit retag flag offensive close merge delete


anyone please?

Asim Arif gravatar image Asim Arif  ( 2015-11-18 20:13:38 -0600 )edit

Hi! Were you able to find answer? I'm currently having the same issue. Thanks!

KennyxD gravatar image KennyxD  ( 2020-11-11 20:41:40 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-02-09 07:28:39 -0600

sobot gravatar image


The current Serial Module of the rplidar is not capable of generating PWM signals itself, therefore there is not an option to tweak in the source code, etc. But you need to use an external source to generate and feed the control signal to the device, e.g. an Arduino board, if you wish to modify the LIDAR's frequency.

You can find the devices PIN information in Section 3 of the devkit_manual.

and here you can read about how to work with PWM in Arduino.

Hope it helps.

edit flag offensive delete link more

answered 2018-05-21 12:11:21 -0600

updated 2018-05-21 12:11:45 -0600

I have changed the RPLIDAR A2 driver to accept the PWM frequency as a parameter at:

In the launch file that you use to start the laser driver, just add:

<param name="motor_pwm" value="..."/>

to the "rplidar_ros" node. The value is 660 by default.

edit flag offensive delete link more



Hello, is this pkg applicable to RPLIDAR A1M8?

pans7 gravatar image pans7  ( 2020-03-04 10:00:58 -0600 )edit

I would also like to know if we can simply add this to RPLidar A1 launch files as well. Thank you.

KennyxD gravatar image KennyxD  ( 2020-10-31 18:56:41 -0600 )edit

I don't think it works on my RPLIDAR A1M8 :( Here is my launch file code:

<launch> <arg name="motor_pwm" default="660"/> <node name="rplidarNode" pkg="rplidar_ros" type="rplidarNode" output="screen">
</node> </launch>

I think, my RPLidar speed doesn't change when I change the motor_pwm value.

winterwoods12 gravatar image winterwoods12  ( 2022-12-18 23:48:48 -0600 )edit

Question Tools

1 follower


Asked: 2015-11-16 23:59:32 -0600

Seen: 4,527 times

Last updated: May 21 '18