Ask Your Question
0

Can't run rtabmap from roslaunch

asked 2016-04-19 15:54:12 -0600

jacksonkr_ gravatar image

updated 2016-04-19 18:17:30 -0600

gvdhoorn gravatar image

I installed rtabmap with $ sudo apt-get install ros-indigo-rtabmap-ros but I'm not able to launch it as expected:

$ roslaunch rtabmap_ros rtabmap.launch
[rtabmap.launch] is neither a launch file in package [rtabmap_ros] nor is [rtabmap_ros] a launch file name
The traceback for the exception was written to the log file

Because I installed a premade binary do I need to create my own launch files? If so, where/how do I do that?

I've tried to build from source but I'm running into a number of pcl/openni issues. Both are installed and working but I believe there's some sort of conflict with how I built one or both of them. Unfortunately the error output is so long that it fills up the terminal so far that I can't even scroll up to see the beginning. I'm recompiling PCL right now with all related options enabled to see if that will help (it's taking some time).

Suggestions?

* EDIT *

I trying to compile on both an armv7 and x86_64. Here's the much smaller error output of the armv7:

$ make
[  6%] Built target rtabmap_utilite
[  7%] Built target res_tool
[ 42%] Built target rtabmap_core
[ 87%] Built target rtabmap_gui
Linking CXX executable ../../../bin/rtabmap
../../../bin/librtabmap_core.so.0.11.4: undefined reference to `pcl::OrganizedFastMesh<pcl::PointXYZRGBNormal>::performReconstruction(pcl::PolygonMesh&)'
../../../bin/librtabmap_core.so.0.11.4: undefined reference to `pcl::OrganizedFastMesh<pcl::PointXYZRGBNormal>::performReconstruction(std::vector<pcl::Vertices, std::allocator<pcl::Vertices> >&)'
collect2: error: ld returned 1 exit status
make[2]: *** [../bin/rtabmap] Error 1
make[1]: *** [app/src/CMakeFiles/rtabmap.dir/all] Error 2
make: *** [all] Error 2

Do I need to add the OrganizedFastMesh file somewhere?

edit retag flag offensive close merge delete

Comments

1

The binaries (0.10) don't install rtabmap.launch. You can have the same functionality with rgbd_mapping.launch or stereo_mapping.launch like in the tutorials.

matlabbe gravatar imagematlabbe ( 2016-04-20 07:07:45 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-19 22:09:53 -0600

jacksonkr_ gravatar image

This was either a PCL or OpenNi issue but I'm not sure which. I reformatted my pc and installed ROS followed by rtabmap and everything worked fine.

I may have been able to install https://github.com/introlab/rtabmap_r... anyway but I had reinstalled Ubuntu before I found out I could build the rtabmap launch tools independently.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-19 15:54:12 -0600

Seen: 551 times

Last updated: Apr 19 '16