Ask Your Question
0

[skeleton.launch] is neither a launch file in package [skeleton_markers] nor is [skeleton_markers] a launch file

asked 2015-11-12 04:43:36 -0500

adelleodel gravatar image

updated 2015-11-12 04:44:16 -0500

Hello, i had this strange error. a few days ago, i've succeed catkin_make and roslaunch skeleton_markers skeleton.launch . so the program successfully running. But, because of i have some error code for my other package on my workspace, someone said that i have to delete the 'build' folder in my workspace and re build my package, but i accidentally delete (with SHIFT+DEL) my install folder (which is source of my install/setup.bash). --this is my stupid accident-- after that, i remake my install folder by catkin_make install in my workspace folder with source in my devel/setup.bash and rebuild with catkin_make, and change again my source to install/setup.bash, and rebuild again with catkin_make.

but still, the result is said that :

 [skeleton.launch] is neither a launch file in package [skeleton_markers] nor is [skeleton_markers] a launch file

i've done re-package my package folder by catkin_create-pkg, but the result still same. i don't know anymore what i have to do with this. please help me :"(

oh, and it's not only that package which have error, but i think all my package inside my workspace can't be launched :( i can find my rospackage with rospack find <package>

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2015-11-12 04:47:58 -0500

Akif gravatar image

updated 2015-11-12 08:07:15 -0500

I think the best way you should follow is backing up your packages, deleting your catkin workspace and creating your workspace again with catkin_init_workspace . After you can put your packages back and run catkin_make. Do not forget to source your devel/setup.bash in your .bashrc file or running source /home/<username>/<catkin_ws>/devel/setup.bash in your terminal.

UPDATE

In your .bashrc, you should have:

source /opt/ros/indigo/setup.bash
source ~/ros/devel/setup.bash

Also, seems like your ROS_PACKAGE_PATH variable is outdated. In your terminal, can you run;

export ROS_PACKAGE_PATH=/home/adelleodel/ros/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks
edit flag offensive delete link more

Comments

I've try it for devel/setup.bash before.. and i hv problem with openni library (problem when catkin_make) that can't find openni package though the file was there, and the problem solved by changing my source to install/setup.bash (i don't know why). But i'll try again with ROS_PACKAGE_PATH update

adelleodel gravatar imageadelleodel ( 2015-11-12 08:28:59 -0500 )edit

Yeah, i succesfully can launch one of my packages. But, i still have another packages that still stuck in my old workspace path. It still respond same error, and when i rospack find package, it said that /home/adelleodel/rosadel/install/share/my_package what to do?

adelleodel gravatar imageadelleodel ( 2015-11-12 10:26:02 -0500 )edit

Ahhh it seems that i haven't move that package /lol Thankyou so much for your help Akif!!! ^^

adelleodel gravatar imageadelleodel ( 2015-11-12 10:30:11 -0500 )edit

I'm glad you figured it out!

Akif gravatar imageAkif ( 2015-11-12 14:32:16 -0500 )edit

I get this error all the time! What a flaky system! Sourcing setup.bash fixes it SOMETIMES. It's not working now.

Alan8 gravatar imageAlan8 ( 2019-06-28 12:25:37 -0500 )edit
0

answered 2015-11-12 05:19:17 -0500

adelleodel gravatar image

Thank you for your respond Akif. i've done those step, but the result still the same. the strange is, my path which i put it in .bashrc is only

  source /opt/ros/indigo/setup.bash
  source ~/ros/install/setup.bash

but when printenv | grep ROS

in my ROS_PACKAGE_PATH=/home/adelleodel/ros/install/share:/home/adelleodel/ros/install/stacks:/home/adelleodel/rosadel/install/share:/home/adelleodel/rosadel/install/stacks:/home/adelleodel/rosadel/src:/opt/ros/indigo/share:/opt/ros/indigo/stack

my old workspace is include the ROS_PACKAGE_PATH (which is rosadel) and my new workspace (which is ros) though i don't write source ~/rosadel/install/setup.bash (i'm using setup.bash in install folder, can i do that?)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-12 04:43:36 -0500

Seen: 359 times

Last updated: Nov 12 '15