Actionlib Tutorial: not found

asked 2015-10-31 12:06:06 -0500

d7x gravatar image

updated 2015-11-02 19:35:33 -0500

I'm running the tutorial Writing a Simple Action Server using the Execute Callback (Python) but getting errors that the file isn't installed. I don't see a directory named simple_action_servers that is supposed to contain this file according to the directions in ( )

ubuntu@ubuntu python
python: can't open file '': [Errno 2] No such file or directory

I'm running Indigo on Ubuntu 14.04 and just reinstalled ros-indigo-common-tutorials but I'm getting the same result. Do I need to install the actionlib_tutorials from a separate package than common tutorials or do I need to create the file?

NEW PROBLEM DATA In order to make this issue easier to understand, I'm providing additional info. When looking at the contents of the actionlib_tutorial in [ ), it states that The following code can be found in actionlib_tutorials/simple_action_servers/, and implements a python action server for the fibonacci action. However, when I run an ls, the simple_action_servers directory has not been installed.

ubuntu@ubuntu:/opt/ros/indigo/share/actionlib_tutorials$ ls action cmake msg package.xml

As part of the tutorial, should I create the directory as well as (and for the next tutorial, Or, does this indicate a bad install?

edit retag flag offensive close merge delete