Ask Your Question
0

Point Grey Camera Image Consistency Issue Exactly 50%

asked 2015-10-23 11:42:04 -0600

davelkan gravatar image

I'm running Ubuntu 14.04 with Indigo and a point grey blackfly. Every second time I run my launch file, which includes the camera launch exert below, I get an endless stream of camera consistency errors and no images. And by every second time I mean exactly and only every other time. I tried increasing socket buffer size to no benefit. The problem seems to occur regardless of which camera nodelets I run.

<!-- Point Grey Blackfly -->

<arg name="camera_serial" default="0" />
<arg name="calibrated" default="0" />

  <group ns="camera">
    <node pkg="nodelet" type="nodelet" name="camera_nodelet_manager" args="manager" />
    <node pkg="nodelet" type="nodelet" name="camera_nodelet"
      args="load pointgrey_camera_driver/PointGreyCameraNodelet camera_nodelet_manager" >
      <param name="frame_id" value="$(arg sensor_frame_prefix)/camera_link" />
      <param name="serial" value="$(arg camera_serial)" />
      <param name="frame_rate" value="10" />
      <param name="camera_info_url" if="$(arg calibrated)"
        value="file://$(env HOME)/.ros/camera_info/$(arg camera_serial).yaml" />
    </node>
    <node pkg="nodelet" type="nodelet" name="image_proc_debayer"
      args="load image_proc/debayer camera_nodelet_manager">
    </node>
    <node pkg="nodelet" type="nodelet" name="rectify_mono"
      args="load image_proc/rectify camera_nodelet_manager">
    </node>
</group>

The error is:

[ERROR] [1445558727.357774357]: PointGreyCamera::grabImage Failed to retrieve buffer | FlyCapture2::ErrorType 41There is an image consistency issue with this image.

Anyone experienced this problem? Anyone have any idea how to resolve this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-23 12:14:45 -0600

That's ..interesting. I also got a a lot of image consistency errors on our Atlas's SA Camera until I enabled the "packet resend" feature of the Flycapture API. See here for an example of how this option is set.

The symptoms you describe sound somewhat differently (working every other time you start), but these are some other observations I made before enabling the resend option fixed things for me:

  • High load on the Network caused significantly more image consistency errors.

  • Increasing the MTU size significantly reduced the number of image consistency errors

edit flag offensive delete link more

Comments

Unfortunately i'm still having this issue. I'm attempting to use the drivers on your git and and getting a compilation error on " fatal error: flycapture/FlyCapture2.h: No such file or directory #include "flycapture/FlyCapture2.h" is there a dependency i missed?

thanks

davelkan gravatar imagedavelkan ( 2015-11-16 13:10:09 -0600 )edit

You need to have the Flycapture2 SDK by Point Grey installed. See https://www.ptgrey.com/support/downloads . We used FlyCapture 2.6.3.4 - Linux (64-bit)

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2015-11-17 12:25:20 -0600 )edit

Did you find a solution to that Issue since then? I'm using only one camera

ROSkinect gravatar imageROSkinect ( 2017-06-08 08:02:59 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-23 11:42:04 -0600

Seen: 1,681 times

Last updated: Oct 23 '15