Ask Your Question
0

robot unable to go in reverse to avoid obstacles

asked 2015-10-21 10:27:36 -0500

Naman gravatar image

updated 2015-10-21 10:27:59 -0500

Hi all,

I have a robot with dimensions (LxWxH) in cm: 82x64x104 and the rotational center is 8 cm from the back of the robot. I am using rotary encoders to get the odometry message. I am using amcl for localization and move_base for planning with TrajectoryPlannerROS as the local planner and sbpl_lattice_planner as global planner.

Everything seems to be working good except in the case when an obstacle comes suddenly in front of the robot. In this case, robot stops but instead of going in reverse (I have specified escape_vel: -0.2) and then continuing on its path (or replanning and then continuing on the new path), it prefers to turn in place and rotates a complete circle (almost) with some jerks and then continues on the path which does not look very elegant. I will prefer that the robot stops, goes in reverse and then continues on its path. What changes do I have to make to do something like this? Let me know if you need more information from me.

Thanks in advance.
Naman Kumar

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-10-23 01:59:02 -0500

Procópio gravatar image

Try to set min_vel_x to a negative value.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-10-21 10:27:36 -0500

Seen: 195 times

Last updated: Oct 23 '15