Not received published messages via rosbridge TCP server

asked 2015-10-06 07:23:41 -0600

JxSun gravatar image

Hi, I am new to ROS and rosbridge. I have followed the below tutorial to get my rosbridge environment ready. http://wiki.ros.org/rosbridge_suite/T...

Then I tried to launch rosbridge TCP server by
roslaunch rosbridge_server rosbridge_tcp.launch

and started publishing messages from a remote device. However, I couldn't successfully receive the messages as expected.

I published some messages to a topic called /my_topic from my device, and used rostopic echo /my_topic to check the incoming messages, but none of them was received. Therefore, I tried to force add some debug logs in rosbridge's python source files to confirm the correctness of my message content and format, and everything just seems normal...

Could someone kindly give me some hints or suggestions? Thanks.

PS: My OS is Ubuntu 14.04, and ROS version is indigo.

edit retag flag offensive close merge delete

Comments

Did you find a solution to your problem because I'm facing the same problem.

userRCH gravatar image userRCH  ( 2017-02-05 11:40:22 -0600 )edit

i'm facing too

PorPorPor gravatar image PorPorPor  ( 2018-07-08 13:47:20 -0600 )edit