ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosserial_arduino: URDF library fail to generate (missing dependencies)

asked 2015-10-04 04:32:59 -0500

Kiroja gravatar image

updated 2015-12-27 06:56:06 -0500

gvdhoorn gravatar image


I am trying to setup the Arduino IDE according to the tutorial -> However, I ran into this problem at the last step where i run the following command.

rosrun rosserial_arduino .

At the terminal, I received the result below. Any insight on what caused this and how to fix this? Thank you.

 *** Warning, failed to generate libraries for the following packages: ***
    urdf_tutorial (missing dependency: convex_decomposition)
Traceback (most recent call last):
  File "/home/user/catkin_ws/install/share/rosserial_arduino/", line 91, in <module>
    rosserial_generate(rospack, path+"/ros_lib", ROS_TO_EMBEDDED_TYPES)
  File "/home/user/catkin_ws/install/lib/python2.7/dist-packages/rosserial_client/", line 584, in rosserial_generate
    raise Exception("Failed to generate libraries for: " + str(failed))
Exception: Failed to generate libraries for: ['urdf_tutorial (missing dependency: convex_decomposition)']
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2015-10-12 07:07:37 -0500

mimooh gravatar image

under ubuntu: sudo apt-get install ros-jade-convex-decomposition

edit flag offensive delete link more

answered 2015-12-27 04:12:21 -0500

science00000 gravatar image

May be get another err missing ivcon package
try also : sudo apt-get install ros-jade-ivcon
deleted ros_lib in : /home/uer/sketchbook/libraries
re-run : rosrun rosserial_arduino .

edit flag offensive delete link more

answered 2017-01-05 09:19:37 -0500

Edu gravatar image

It worked for me. Thanks a lot!!

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-10-04 04:32:59 -0500

Seen: 1,020 times

Last updated: Jan 05 '17