Ask Your Question
0

Kinect in ROS

asked 2015-10-01 03:12:19 -0500

wairr92 gravatar image

I was tracking a person using Kinect for Windows in ROS.

rosrun openni_tracker opennI_tracker

It worked well, until I tried install openni_launch by this command:

sudo apt-get install ros-indigo-openni-launch

Now when I run

rosrun openni_tracker opennI_tracker

I get this error:

InitFromXml failed: Can't create any node of the requested type!

Things which I tried:

1.) sudo apt-get purge ros-indigo-openni-launch

2.) reinstall NITE version 1.5.2.23

3.) reinstall all kinect drivers

but nothing works.

edit retag flag offensive close merge delete

Comments

I receive this error also when running that same command. I have installed openni_tracker differently using the instructions found here.

Inder gravatar image Inder  ( 2015-11-13 15:15:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-13 16:48:46 -0500

Getting all of these pieces working together on a random computer can often be a bit tricky! I wrote this answer a long time ago that is still my number one resource on how to get everything working together. A few other debugging points:

  1. If you can, try to avoid using USB 3.0 ports.
  2. If having issues, make sure that XnSensorServer process is not still running.
  3. Try unplugging the Kinect and then running sudo service udev reload. Plug back in and try again.
  4. Since you are using NITE 1.5.2.23, try installing the OpenNI SDK v1.5.7.10 from here

Sometimes the points from this answer can also be helpful.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-10-01 03:12:19 -0500

Seen: 232 times

Last updated: Nov 13 '15