Ask Your Question
2

running sbpl_lattice_planner on Nvidia Jetson TK1

asked 2015-09-07 15:08:13 -0500

Naman gravatar image

Hi all,

I have a mobile robot which is navigating around a room, I already have the map of the room. I am using the navigation_stack of ROS. I am using rotary encoders for odometry. I am fusing the data from Rotary encoders and IMU using robot_pose_ekf. I am using amcl for localization and move_base for planning with sbpl_lattice_planner as the global planner. Everything seems to be working on my dell laptop (with intel processor).

Now, when I port everything to Nvidia Jetson TK1, the sbpl_lattice_planner does not seem to be working (the default A* planner works). It is very weird because the exact same code works on the laptop. I highly doubt that it is happening because the time to come up with the plan for sbpl_lattice_planner is less in case of Nvidia Jetson. I feel the problem is there because Nvidia Jetson has an ARM processor whereas my laptop has an intel processor and therefore sbpl_lattice_planner is not able to come up with a plan (or a complete plan) in case of Nvidia Jetson but I am not able to figure out how to resolve this issue. Also, sometimes if I give a goal say 10 m away from the starting position, it only comes up with a plan till 2-3 m from the starting position. See image (I gave the goal on the top right of the room but the the plan is only till couple of meters):
image description

I am using sbpl and sbpl_lattice_planner.

I have tried following but it was of no help:
1. Decreasing number of SBPL primitives.
2. Increasing the global_planner timeout.
3. Decreasing the global_costmap resolution.

Does anyone have any idea why is this happening and how can it be resolved? Let me know if you need more information from my side.

Thanks in advance.
Naman Kumar

edit retag flag offensive close merge delete

Comments

Hello Naman, did you fix your problem? About SBPL, what pose_follower are you using? Could you show the parameters of your navigation package? I am experiencing some problems with SBPL. Thank you.

solosito gravatar imagesolosito ( 2016-02-18 03:23:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-09-07 18:43:39 -0500

ahendrix gravatar image

There is a bug in SBPL because it expects char to be signed on ARM; you may want to try this patch, and comment on it if it works for you: https://github.com/sbpl/sbpl/pull/27

edit flag offensive delete link more

Comments

This worked for me..Thanks a lot! :)

Naman gravatar imageNaman ( 2015-09-23 07:31:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-09-07 15:08:13 -0500

Seen: 241 times

Last updated: Sep 07 '15