Ask Your Question
0

Error in Understanding ROS Topics Tutorial [closed]

asked 2015-09-01 14:33:21 -0500

jeffthardy gravatar image

I did a quick search and didn't see this reported.

http://wiki.ros.org/ROS/Tutorials/Und...

For the Hydro and later case, it looks like there is a missing negative sign for the angular velocity when attempting to get the turtle to continuously move in a circle. I've highlighted this below. I haven't actually run this code, but I'm pretty sure that was a mistake since it is the same thing run earlier in the tutorial and the image shows it turn the opposite direction.

For ROS Hydro and later,

$ rostopic pub /turtle1/cmd_vel geometry_msgs/Twist -r 1 -- '[2.0, 0.0, 0.0]' '[0.0, 0.0, 1.8]'

For ROS Groovy and earlier,

$ rostopic pub /turtle1/command_velocity turtlesim/Velocity -r 1 -- 2.0 -1.8

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by jeffthardy
close date 2015-09-02 09:30:34.573068

Comments

Please do not delete questions unless they are spam or significantly off-topic. Old questions serve as a record of things that other users have had trouble with, and may aid new users in the future.

ahendrix gravatar image ahendrix  ( 2015-09-04 02:06:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-09-02 02:41:54 -0500

gvdhoorn gravatar image

The ROS Wiki is just that, a Wiki :). If you feel this is an error and you've made sure that your proposed change fixes something that is wrong, you can correct it on the page itself. If you don't have an account, first register for one. If other ppl think it's not ok, it'll be changed back.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-09-01 14:33:21 -0500

Seen: 49 times

Last updated: Sep 01 '15