Performing skeleton tracking with ros-skeltrack

asked 2015-08-30 15:26:07 -0600

ishareef gravatar image

updated 2015-08-30 15:48:42 -0600

In response to the buyout of OpenNI/NiTE, I tried to explore an open source alternative Skeltrack. I came across a helpful ROS wrapper for Skeltrack here ( ).

So as to provide the /tf topic that this package depends on, I ran openni_launch in one shell of my Ubuntu 14.04 system. In another shell I ran rosrun ros_skeltrack ros_skeltrack_node. I'm using an ASUS Xtion and not a Kinect, which is why I'm not using GFreenect (as recommended by the author of Skeltracker).

It seemed to compile, however I couldn't figure out how to visually detect or track a skeleton. My first instinct was to use the same settings on RViz -- as this worked with openni_tracker. However, the ros_skeltrack package did not seem to work the same way.

In fact, when I ran rosnode info skeletor_processor on the relevant node that was published, I got the following output:

Node [/skeletor_processor] Publications:   * /rosout [rosgraph_msgs/Log]

Subscriptions:   * /camera/depth/image_raw [sensor_msgs/Image]

Services:   * /skeletor_processor/get_loggers  * /skeletor_processor/set_logger_level

contacting node http://[omitted]/ ... Pid: 10724 Connections:  * topic: /rosout
    * to: /rosout
    * direction: outbound
    * transport: TCPROS  * topic: /camera/depth/image_raw
    * to: /camera/camera_nodelet_manager (http://[omitted]/)
    * direction: inbound
    * transport: TCPROS

Unlike with openni_tracker, nothing was being published by the wrapper.

Any thoughts, hints in the right direction, or ideas would be very helpful and appreciated.

edit retag flag offensive close merge delete