Ask Your Question
0

OpenNI launching error process[camera/driver-3]

asked 2013-10-23 00:40:35 -0500

Wojciech gravatar image

updated 2016-10-24 08:36:47 -0500

ngrennan gravatar image

Hello, I tried to launch

roslaunch openni_launch openni.launch

and got this error:

process[camera/driver-3]: started with pid [21833]
[ERROR] [1382523364.281865460]: Failed to load nodelet [/camera/driver] of type [openni_camera/driver]: According to the loaded plugin descriptions the class openni_camera/driver with base class type nodelet::Nodelet does not exist. Declared types are  ccny_rgbd/RGBDImageProcNodelet depth_image_proc/convert_metric depth_image_proc/disparity depth_image_proc/point_cloud_xyz depth_image_proc/point_cloud_xyzrgb depth_image_proc/register image_proc/crop_decimate image_proc/debayer image_proc/rectify image_view/disparity image_view/image nodelet_tutorial_math/Plus pcl/BAGReader pcl/ExtractIndices pcl/NodeletDEMUX pcl/NodeletMUX pcl/PCDReader pcl/PCDWriter pcl/PassThrough pcl/PointCloudConcatenateDataSynchronizer pcl/PointCloudConcatenateFieldsSynchronizer pcl/ProjectInliers pcl/StatisticalOutlierRemoval pcl/VoxelGrid stereo_image_proc/disparity stereo_image_proc/point_cloud stereo_image_proc/point_cloud2
[FATAL] [1382523364.282295582]: Service call failed!

Anyone knows what's wrong? Kinect is not yet connected. I have Ubuntu 12.4 OS and ROS Hydro.

edit retag flag offensive close merge delete

Comments

Please state what software (OS and ROS) and versions you are using (use tags for that as well).

bit-pirate gravatar image bit-pirate  ( 2013-10-23 13:53:46 -0500 )edit

32 or 64bit? Did you install the openni packages (```sudo apt-get install ros-hydro-openni-launch```)?

bit-pirate gravatar image bit-pirate  ( 2013-10-27 15:48:17 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2013-11-04 05:46:37 -0500

Wojciech gravatar image

Thank you it worked after:

sudo apt-get install ros-hydro-openni*

Please close this question.

edit flag offensive delete link more

Comments

To close a question, just accept an answer (click the checker sign below the answer's votes).

bit-pirate gravatar image bit-pirate  ( 2013-11-04 11:39:19 -0500 )edit
0

answered 2013-11-03 09:32:01 -0500

Athoesen gravatar image

updated 2013-11-04 10:21:00 -0500

Anyone knows what's wrong? Kinect is not yet connected. I have Ubuntu 12.4 OS and ROS Hydro.

Do you mean you tried to run the launch without having the Kinect plugged in? I would get all of the openni packages. Try "sudo apt-get install ros-hydro-openni*" with the star to download all Hydro openni associated packages

edit flag offensive delete link more
0

answered 2014-04-08 20:51:47 -0500

Rizwan gravatar image

still i have an error usb interface not supported. or running the os.

edit flag offensive delete link more

Comments

the packages installed successfully but the kinect driver still not recognize the driver of the usb.

Rizwan gravatar image Rizwan  ( 2014-04-23 22:42:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-23 00:40:35 -0500

Seen: 1,621 times

Last updated: Apr 08 '14