Ask Your Question
0

Phantom Omni / Geomagic Touch package compile error

asked 2015-08-14 10:43:26 -0600

ahmadataka gravatar image

Hi guys.

I have some problems when I compile the package provided to use Geomagic Touch (formerly Sensable Phantom Omni). I already tried three packages provided for ROS Fuerte ( http://wiki.ros.org/phantom_omni ), ROS Groovy ( https://github.com/danepowell/phantom... ), and ROS Hydro ( https://github.com/fsuarez6/phantom_omni ). Every time I make the package, the errors occur as follows

/usr/bin/ld: skipping incompatible /usr/lib/gcc/i686-linux-gnu/4.6/../../../../lib/libHD.so when searching for -lHD /usr/bin/ld: skipping incompatible /usr/lib/gcc/i686-linux-gnu/4.6/../../../../lib/libHDU.a when searching for -lHDU

I already tried the suggestion provided here ( http://wiki.ros.org/phantom_omni ), using '/usr/lib' directory on my system instead of '/usr/lib64', but the errors are still there. I'm now using ROS Fuerte and Hydro installed on Ubuntu 12.04. I use OpenHaptics 3.4-0.

Best regards, Ataka

edit retag flag offensive close merge delete

Comments

I'm also interested in this solution - did you manage to make it working? I got following error while compiling "ROS Node for Sensable Phantom Omni device"on Ubuntu 14.04.4 LTS ROS Indigo (/usr/bin/ld: cannot find -lncurses collect2: error: ld returned 1 exit status)

gtm gravatar imagegtm ( 2016-03-26 09:39:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-10-01 11:19:22 -0600

ZainMehdi gravatar image

I also had the same issue. Try compiling the code as a super user ... "sudo -s" and then catkin_make , the code will compile and you will be able to see rviz window. however the model was a bit imperfect but still better than nothing .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-08-14 10:43:26 -0600

Seen: 428 times

Last updated: Aug 14 '15