Ask Your Question
0

p2os error- setup failed

asked 2015-08-03 14:56:27 -0500

ROS_Fan gravatar image

I want to use p2os to control the Amigobot. I am now using Ubuntu 14.04 with ROS Indigo. The Amigobot is connected to my laptop via USB port. I have successfully installed the p2os-purdue. But when I try rosrun p2os_driver p2os_driver. I have the following error:

fan@Fan--PC:~/test_ws$ rosrun p2os_driver p2os_driver _port:=/dev/ttyUSB0
[ INFO] [1438630934.277844305]: using serial port: [/dev/ttyUSB0]
[ INFO] [1438630934.314938066]: P2OS connection opening serial port /dev/ttyUSB0
...
[ INFO] [1438630935.716930912]: SYNC0
[ INFO] [1438630935.917268096]: turning off NONBLOCK mode...
[ INFO] [1438630936.117623204]: SYNC1
[ INFO] [1438630936.518107007]: SYNC2
[ INFO] [1438630937.118764772]: Done.
   Connected to SUNY_509, a Pioneer Amigo-sh
[ERROR] [1438630939.522397962]: p2os setup failed...

I have read the similar problem here. It seems that I have same problem with sealguy77. But after I try sudo chmod 777 -R /dev/ttyUSB0 , I still get the same error: [ERROR] [1438631499.971642893]: p2os setup failed...

edit retag flag offensive close merge delete

Comments

Hm... Interesting. I'll take a look at this later. What version of p2os are you using?

allenh1 gravatar image allenh1  ( 2015-08-03 17:48:05 -0500 )edit

It is 2.0.1.

ROS_Fan gravatar image ROS_Fan  ( 2015-08-03 18:17:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-08-04 06:29:35 -0500

allenh1 gravatar image

Apologies! There is an issue in the code. I have just fixed it, and will be re-releasing p2os for jade. Please use the git version of the code. The updated binaries should be available on the next update cycle.

edit flag offensive delete link more

Comments

Thank you! It works now : )

ROS_Fan gravatar image ROS_Fan  ( 2015-08-05 08:47:23 -0500 )edit

Glad to hear it! I made a pretty bizarre error, if you were curious. I had: if (!p2os->Setup()){ /** exit on error **/} But needed to have if (p2os->Setup()){/** exit on error **/}. I will be changing the API, as this is just unnecessarily confusing... XD

allenh1 gravatar image allenh1  ( 2015-08-05 13:07:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-08-03 14:56:27 -0500

Seen: 323 times

Last updated: Aug 04 '15