Ask Your Question
2

Starting p3dx using p2os

asked 2011-12-09 05:43:31 -0500

karthik gravatar image

Hi, I am following the tutorials in http://www.ros.org/wiki/p2os/Tutorials/Getting%20Started%20with%20p2os

I have only one laptop mounted on the robot (p3dx) hence i am not following the 7th and 8th section of the above mentioned tutorial.

When i run the

rosrun p2os_dashboard p2os_dashboard

i see the dashboard getting displayed but except the Rosout (in green) ui others are not colored (red/green) and the battery is 0% even though the robot is fully charged. I am not able to enable or disable the motors. I see the problem is here itself.

And when i run the

rosrun p2os_drivers p2os

i get the following errors.

[ INFO] [1323459143.327099680]: using serial port: [/dev/ttyS0]
[ INFO] [1323459143.360479690]: P2OS connection opening serial port /dev/ttyS0...
[ERROR] [1323459143.360617485]: P2OS::Setup():tcgetattr():
[ERROR] [1323459143.360707540]: p2os setup failed...

I have given the read and write permissions to ttyS* and ttyUSB*. I am able to use ROSARIA and get the robot moving using keyboard operations. I am sure something is being missed. Pls let me know

Thanks, Karthik

edit retag flag offensive close merge delete

Comments

I am using ROS electric on ubuntu 11.04
karthik gravatar imagekarthik ( 2011-12-09 05:43:56 -0500 )edit
Can anyone help me here. Got stuck at this point. Thanks
karthik gravatar imagekarthik ( 2011-12-13 05:21:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-12-15 08:42:01 -0500

karthik gravatar image

updated 2012-03-28 08:15:06 -0500

Ok found the issue. Had to remap the param name port to /dev/ttyUSB0 Its working now

Thanks, Karthik


You may update the param at ./p2os_driver/include/p2os_driver/robot_params.h but beware that the sick laser usage might have a conflict at this port. You may have it as a param in the launch file.

edit flag offensive delete link more

Comments

Hi Karthik, I can connect my robot with laptop by using serial-usb cable. I'm trying to control robot using keyboard. when i run $rosrun p2os_dashboard p2os_dashboard i get ImportError: No module named msg. Can you please help me out.

cognitiveRobot gravatar imagecognitiveRobot ( 2013-10-21 00:40:29 -0500 )edit

I am not sure of it! Can you post it as a new question!

karthik gravatar imagekarthik ( 2013-11-05 02:59:35 -0500 )edit

Thanks. i managed to get it done using rosAria

cognitiveRobot gravatar imagecognitiveRobot ( 2013-11-06 06:03:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-12-09 05:43:31 -0500

Seen: 1,865 times

Last updated: Mar 28 '12