Kinect 2 : Failed to create opengl window [closed]

asked 2015-07-29 22:10:40 -0500

Robopreneur gravatar image


I'm trying to follow the iai_kinect2 tutorial which uses kinect 2 for ROS.

I encountered a problem when executing rosrun kinect2_bridge kinect2_bridge where I have the following output:

parameter: base_name: kinect2 sensor: fps_limit: -1 calib_path: /home/roma/kinect2_ws/src/iai_kinect2/kinect2_bridge/data/ use_png: false jpeg_quality: 90 png_level: 1 depth_method: opengl depth_device: -1 reg_method: opencl reg_devive: -1 max_depth: 12 min_depth: 0.1 queue_size: 2 bilateral_filter: true edge_aware_filter: true publish_tf: false base_name_tf: kinect2 worker_threads: 4

[OpenGLDepthPacketProcessor] Failed to create opengl window.

The main problem seems to be on the package of libfreenect2 which is a dependency of iai_kinect2.

I successfully installed libfreenect2 , however, when executing ./bin/Protonect in the designated folder, I get the following information:

[Freenect2Impl] enumerating devices... [Freenect2Impl] 12 usb devices connected [Freenect2Impl] found valid Kinect v2 @4:7 with serial 034427151247 [Freenect2Impl] found 1 devices [OpenGLDepthPacketProcessor] Failed to create opengl window.

It seems that the core problem is with opengl, but I downloaded an Opengl tutorial from and can launch at least an blank opengl window without any problem.

Does anyone have any idea of what is happening here?

Thanks in advance!


edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-04-15 03:03:06.596898


I am also getting the same error. Is anyone working in this?

KDROS gravatar image KDROS  ( 2015-08-14 02:09:43 -0500 )edit

I have the same error too. Have you solved it?

smithers gravatar image smithers  ( 2015-08-31 07:03:48 -0500 )edit

@Robopreneur@smithers i'm working with the Kinect 2 and i was having a similar problem. When i ran the kinect2_viewer i just got worked the rgb camera, and for the ir/depth camera i just was seeing a black window. So, i installed the latest drivers for my graphic card and it solved my problem.

jaam002 gravatar image jaam002  ( 2015-08-31 09:08:02 -0500 )edit

Where you able to solve this ? I am running into similar problem. I'm trying to run ibfreenect 2 on Intel NUC -NUC5i7RYH with Ubuntu 14.04.4 LTS

pnambiar gravatar image pnambiar  ( 2016-04-12 13:50:13 -0500 )edit