Ask Your Question
0

how to install a ROS stack to catkin workspace

asked 2015-07-27 13:52:00 -0600

Che. gravatar image

updated 2015-07-27 13:52:29 -0600

i'd like to install certain ROS stacks to my catkin workspace. ive already cloned them from github to my src folder insider my workspace path.

how to make ROS recognize it?

thank you in advance.

greets, che.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-07-27 16:45:13 -0600

updated 2015-07-27 16:47:28 -0600

Do your packages still contain manifest.xml? If yes you need to port them all to Catkin.

http://wiki.ros.org/catkin/migrating_...

If they are already Catkin packages, you just need to build them with catkin_make, even when in a subfolder of src it should directly build them.

edit flag offensive delete link more

Comments

1

Packages with a manifest.xml can still be compiled with rosbuild, in a separate rosbuild workspace.

ahendrix gravatar imageahendrix ( 2015-07-27 17:26:09 -0600 )edit

as far as i can see there are only package.xml files in each package. did i get it right that i need to catkin_make the single packages? i just tried it and i'm getting closer. when catkin_making the packages i get the error "no rule to make target >packagename<. stop.

Che. gravatar imageChe. ( 2015-07-27 17:52:19 -0600 )edit

@ahendrix, yes but then depending on them by a catkin package is not possible. @che you have to execute catkin_make in the "root" of your workspace if your packages are in catkin_ws/src/... then you have to execute catkin_make in catkin_ws (BTW: don't forget catkin_init_workspace in src)

cyborg-x1 gravatar imagecyborg-x1 ( 2015-07-28 02:38:50 -0600 )edit

@Cyborg when i'm running catkin_init_workspace in catkin_ws/src/ i get the message File "/home/USER/catkin_ws/src/CMakeLists.txt" already existst... it looks like i'm not the owner of CMakeLists.txt ... i've tried to change that with chown but it didn't work.

Che. gravatar imageChe. ( 2015-07-28 05:08:12 -0600 )edit

now i did catkin_make in catkin_ws. it seems that the packages have been built now.

  • is it right, that i always need to repeat that as i'm adding new stacks to my catkin src?

but when i try to execute a node within a package within the new stack ive installed i get the error `package not found

Che. gravatar imageChe. ( 2015-07-28 05:21:44 -0600 )edit
0

answered 2015-07-28 07:45:47 -0600

Che. gravatar image

ok, I had serveral problems. here are some tips to get around the error:

  1. execute catkin_make in root of catkin workspace
  2. add following code to your ~/.bash.rc source your/workspace/path/catkin/devel/setup.bash
  3. restart all terminals
  4. start roscore in a seperate terminal
  5. rosrun your node

for now it works. thanks to all helpers.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-27 13:52:00 -0600

Seen: 377 times

Last updated: Jul 28 '15