Ask Your Question
0

Error: command stage_ros not implemente

asked 2015-07-22 11:34:28 -0500

negotiator14 gravatar image

updated 2015-07-22 14:57:24 -0500

I recently installed stage_ros in my computer but when I try to run using "rosrun stage_ros stageros $(rospack stage_ros)/world/willow-erratic.world" I get the following:

[rospack] Error: command stage_ros not implemented [Loading /world/willow-erratic.world]err: unable to open world file /world/willow-erratic.world : No such file or directory (/tmp/buildd/ros-indigo-stage-4.1.1-4trusty-20150424-0404/libstage/worldfile.cc Load)

I'm not sure if it has something to do with how my environmental variables are set up or if I'm missing something.

EDIT 1

I got stage_ros to work now, I'm able to run thtat command line with no errors, I forgot to add the 'find' key word. This is the output in the command line: $ rosrun stage_ros stageros $(rospack find stage_ros)/world/willow-erratic.world [Loading /opt/ros/indigo/share/stage_ros/world/willow-erratic.world] warn: worldfile /opt/ros/indigo/share/stage_ros/world/willow-erratic.world:21 : property [laser_return] is defined but not used (/tmp/buildd/ros-indigo-stage-4.1.1-4trusty-20150424-0404/libstage/worldfile.cc WarnUnused) Now I'm having some issues installing the controllers, http://wiki.ros.org/stage/Tutorials/I... . I downloaded, extracted and moved the folder to my catkin_ws. I catkin_make it and used the rosmake command but when I run the rosrun command in the tutorial I get the following error:

$ rosrun stage stageros 'rospack find stage_controllers'/world/roomba-wander.world [rospack] Error: package 'stage' not found [rosrun] Couldn't find executable named stageros below

edit retag flag offensive close merge delete

Comments

It should be rosrun stage_ros stageros 'rospack find stage_controllers'/world/roomba-wander.world. The "stage" package became a system dependency and the "stageros" node went into the "stage_ros" wrapper package.

daenny gravatar image daenny  ( 2015-07-23 03:22:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-22 12:32:20 -0500

allenh1 gravatar image

Have you installed stage_ros? And I think you messed up your command a little... This worked on mine: rosrun stage_ros stageros $(rospack find stage_ros)/world/willow-erratic.world

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-22 11:34:28 -0500

Seen: 667 times

Last updated: Jul 22 '15