ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Failing to follow kinect tutorial

asked 2015-07-19 05:14:34 -0500

blubbi321 gravatar image

I am new to ROS in general. I have a kinect and want to follow the tutorial from to see what kind of data comes out of the device.

The error I get when trying to run

roslaunch openni_launch openni.launch


[openni.launch] is neither a launch file in package [openni_launch] nor is [openni_launch] a launch file name
The traceback for the exception was written to the log file

Which led me to which however did not fix the problem. I have tried quite some different packages to (re)install, however the error is always the same.

I have read through the tutorials about ROS filesystem etc, out of which the most most relevant seems to be the one about roslaunch ( ). However, for my problem, the system does not even seem to find the .launch file.

Can anybody help me with this issue? Has something changed, or am I too dump to understand the manual?

Software versions used: Ubuntu 14.04, ROS jade (have also tried the indigo packages)

edit retag flag offensive close merge delete


If you locate openni.launch, do you get anything?

Po-Jen Lai gravatar image Po-Jen Lai  ( 2015-07-19 11:36:35 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2015-07-21 04:18:22 -0500

When I try to install ros-jade-openni-launch, apt-get tells me that it is not there. So due to the fact that ROS Jade is new, the package was not built for Jade by its maintainer yet. Thats why it does not find the package. Either you build openni for jade yourself, or you use ROS indigo. Or ask the maintainer if he would be so kind to release it for you for jade.



edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-07-19 05:14:34 -0500

Seen: 679 times

Last updated: Jul 21 '15