ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to install sensor_msgs on Raspberry Pi

asked 2015-07-15 10:48:45 -0500

Saeid gravatar image

Hi guys,

In need to access to my ROBOPEAK laser scanner. When I want to use Catkin_Make there is an error as below: "Could not find a package configuration file provided by "sensor_msgs" with any of the following names:


I tried to install 'Sensor_msgs' package on my Raspberry Pi but I could not. So please give me a tip to do that. regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-11-13 11:47:53 -0500

ATXCyborg gravatar image

We just ran into the same problem. From what we found, you need to use the rosisntall_generator and wstool commands. Specifically:

rosinstall_generator sensor_msgs --rosdistro indigo --deps -wet-only --tar > indigo-sensor_msgs-wet.rosinstall
wstool init src indigo-sensor_msgs-wet.rosinstall

This worked for us using indigo and for installing the image_transport and cv_bridge packages as well. As a note, we had to delete the previous .rosinstall file in the src directory for these commands to work. Don't know if there's a better solution.

edit flag offensive delete link more


I do appreciate it, works!

Saeid gravatar image Saeid  ( 2015-11-24 08:29:36 -0500 )edit

Question Tools

1 follower


Asked: 2015-07-15 10:48:45 -0500

Seen: 2,813 times

Last updated: Nov 13 '15