Ask Your Question
0

Invalid package manifest "package.xml"

asked 2015-07-13 04:15:01 -0500

Salocin808 gravatar image

updated 2015-07-13 04:36:23 -0500

BennyRe gravatar image

Hi! I found a some entries but none seem to help with my problem. I am currently following the instructions to install turtlebot on this site: http://wiki.ros.org/turtlebot/Tutoria... when running following command under point 2.2:

rosdep install --from-paths src -i -y

I get following stack trace:

nicolas@myworkstation:~/rocon$ rosdep install --from-paths src -i -y

ERROR: Rosdep experienced an error: Invalid package manifest "/opt/ros/indigo/share/catkin/package.xml": Error(s) in /opt/ros/indigo/share/catkin/package.xml:
- The manifest must not contain the following tags: depend, build_export_depend, buildtool_export_depend
Please go to the rosdep page [1] and file a bug report with the stack trace below.
[1] : http://www.ros.org/wiki/rosdep

rosdep version: 0.11.2

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 136, in rosdep_main
    exit_code = _rosdep_main(args)
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 345, in _rosdep_main
    return _package_args_handler(command, parser, options, args)
  File "/usr/lib/python2.7/dist-packages/rosdep2/main.py", line 416, in _package_args_handler
    pkgs = find_catkin_packages_in(path, options.verbose)
  File "/usr/lib/python2.7/dist-packages/rosdep2/catkin_packages.py", line 33, in find_catkin_packages_in
    packages = find_packages(path)
  File "/usr/local/lib/python2.7/dist-packages/catkin_pkg/packages.py", line 87, in find_packages
    package = parse_package(os.path.join(basepath, path))
  File "/usr/local/lib/python2.7/dist-packages/catkin_pkg/package.py", line 315, in parse_package
    return parse_package_string(f.read(), filename)
  File "/usr/local/lib/python2.7/dist-packages/catkin_pkg/package.py", line 448, in parse_package_string
    raise InvalidPackage('Error(s) in %s:%s' % (filename, ''.join(['\n- %s' % e for e in errors])))
InvalidPackage: Invalid package manifest "/opt/ros/indigo/share/catkin/package.xml": Error(s) in /opt/ros/indigo/share/catkin/package.xml:
- The manifest must not contain the following tags: depend, build_export_depend, buildtool_export_depend

There must be a problem with my package.xml file.

It seems that the package version 2 might cause the error but I honestly don't know how to fix it. Does anyone have any ideas? Thanks in advance!

edit retag flag offensive close merge delete

Comments

Can you post the package.xml that causes the problem?

BennyRe gravatar imageBennyRe ( 2015-07-13 04:37:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-13 11:25:05 -0500

Dirk Thomas gravatar image

Your rospkg version is likely outdated. Please see http://answers.ros.org/question/20780...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-07-13 04:15:01 -0500

Seen: 2,668 times

Last updated: Jul 13 '15