Ask Your Question
1

Unable to install Turtlebot

asked 2015-07-11 07:01:41 -0500

Grant Woodford gravatar image

updated 2015-07-12 06:18:21 -0500

I am running ROS Indigo on Ubuntu Trusty but am unable to install Turtlebot from this tutorial: http://wiki.ros.org/turtlebot/Tutoria...

The error I get is:

sudo apt-get install ros-indigo-turtlebot ros-indigo-turtlebot-apps ros-indigo-turtlebot-interactions ros-indigo-turtlebot-simulator ros-indigo-kobuki-ftdi ros-indigo-rocon-remocon ros-indigo-rocon-qt-library ros-indigo-ar-track-alvar-msgs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-turtlebot-simulator : Depends: ros-indigo-turtlebot-gazebo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I am running Ubuntu 14.04.2 LTS on a Acer Aspire S3 laptop, Linux kernal 3.13.0-55-generic x86_64 .

As requested in the feedback, I ran with -f -o Debug::pkgProblemResolver=yes and was still unable to install Turtlebot:

sudo apt-get install -f -o Debug::pkgProblemResolver=yes ros-indigo-turtlebot ros-indigo-turtlebot-apps ros-indigo-turtlebot-interactions ros-indigo-turtlebot-simulator ros-indigo-kobuki-ftdi ros-indigo-rocon-remocon ros-indigo-rocon-qt-library ros-indigo-ar-track-alvar-msgs > allout.txt 2>&1

Reading package lists...
Building dependency tree...
Reading state information...
Starting pkgProblemResolver with broken count: 6
Starting 2 pkgProblemResolver with broken count: 6
Investigating (0) libsdformat2 [ amd64 ] < 2.3.2-1~trusty > ( libs )
Broken libsdformat2:amd64 Conflicts on libsdformat1 [ amd64 ] < none -> 1.4.11-1ubuntu0.1 > ( universe/libs )
  Considering libsdformat1:amd64 -1 as a solution to libsdformat2:amd64 10
  Added libsdformat1:amd64 to the remove list
  Conflicts//Breaks against version 1.4.11-1osrf1 for libsdformat1 but that is not InstVer, ignoring
  Conflicts//Breaks against version 1.4.11-1 for libsdformat1 but that is not InstVer, ignoring
  Fixing libsdformat2:amd64 via keep of libsdformat1:amd64
Investigating (0) libsdformat-dev [ amd64 ] < none -> 1.4.11-1ubuntu0.1 > ( universe/libdevel )
Broken libsdformat-dev:amd64 Depends on libsdformat1 [ amd64 ] < none -> 1.4.11-1ubuntu0.1 > ( universe/libs ) (= 1.4.11-1ubuntu0.1)
  Considering libsdformat1:amd64 -1 as a solution to libsdformat-dev:amd64 3
  Holding Back libsdformat-dev:amd64 rather than change libsdformat1:amd64
Investigating (0) ros-indigo-gazebo4-msgs [ amd64 ] < 2.4.6-0trusty > ( misc )
Broken ros-indigo-gazebo4-msgs:amd64 Conflicts on ros-indigo-gazebo-msgs [ amd64 ] < none -> 2.4.8-0trusty-20150522-1307-+0000 > ( misc )
  Considering ros-indigo-gazebo-msgs:amd64 -1 as a solution to ros-indigo-gazebo4-msgs:amd64 3
  Added ros-indigo-gazebo-msgs:amd64 to the remove list
  Fixing ros-indigo-gazebo4-msgs:amd64 via keep of ros-indigo-gazebo-msgs:amd64
Investigating (0) ros-indigo-gazebo4-ros [ amd64 ] < 2.4.6-0trusty > ( misc )
Broken ros-indigo-gazebo4-ros:amd64 Conflicts on ros-indigo-gazebo-ros [ amd64 ] < none -> 2.4.8-0trusty-20150523-0901-+0000 > ( misc )
  Considering ros-indigo-gazebo-ros:amd64 0 as a solution to ros-indigo-gazebo4-ros:amd64 1
  Added ros-indigo-gazebo-ros:amd64 to the remove list
  Fixing ros-indigo-gazebo4-ros:amd64 via keep of ros-indigo-gazebo-ros:amd64
Investigating (0) ros-indigo-gazebo4-plugins [ amd64 ] < 2.4.6-0trusty > ( misc )
Broken ros-indigo-gazebo4-plugins:amd64 Conflicts on ros-indigo-gazebo-plugins [ amd64 ] < none -> 2.4.8-0trusty-20150523-1223-+0000 > ( misc )
  Considering ros-indigo-gazebo-plugins:amd64 -2 as a solution to ros-indigo-gazebo4-plugins:amd64 0
  Added ros-indigo-gazebo-plugins:amd64 to the remove list
  Fixing ros-indigo-gazebo4-plugins:amd64 via keep of ros-indigo-gazebo-plugins:amd64
Investigating (0) gazebo2 [ amd64 ] < none -> 2.2.5-1~trusty > ( devel )
Broken gazebo2:amd64 Depends on libsdformat-dev [ amd64 ] < none -> 1.4.11-1ubuntu0.1 > ( universe/libdevel ...
(more)
edit retag flag offensive close merge delete

Comments

Please format console copy/pastes with the Preformatted text button (the one with 101010 on it) in the future. Really hard to read otherwise.

gvdhoorn gravatar image gvdhoorn  ( 2015-07-11 07:16:11 -0500 )edit

To get more information from apt add the option -o Debug::pkgProblemResolver=yes to get more information and then edit your question. Please also state your platform (OS, Arch, etc)

tfoote gravatar image tfoote  ( 2015-07-12 03:55:29 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-07-12 20:42:19 -0500

tfoote gravatar image

From your edits you've found the problem. To clarify a little bit. If you upgrade the version of gazebo that you are running from the gazebo repos http://packages.osrfoundation.org you will need to build all packages on top of that from source.

This is because upgrading to the newer version of Gazebo is not ABI compatible and thus the binaries would crash if you tried to use them in a mixed fashion. It would be nice if apt gave more helpful errors by default, but at least the packages conflict so you don't get your system into a crashing state.

edit flag offensive delete link more
0

answered 2015-07-12 00:39:00 -0500

allenh1 gravatar image

It is really hard to say exactly how to fix this issue. This is an apt-get problem more than a ROS problem. You need to figure out what's blocking the install of ros-indigo-turtlebot-gazebo.

When I end up in a situation like this, I would first try sudo apt-get -f install, followed by your command. If that still doesn't work, then you should do sudo apt-get install ros-indigo-turtlebot-gazebo. Pay attention to the packages listed in the output. If the first command doesn't work, please edit your question with the output of the later.

edit flag offensive delete link more

Comments

I am also gettin this error. I tried your solution but I still get same error.

zuygar gravatar image zuygar  ( 2016-03-14 04:03:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-11 07:01:41 -0500

Seen: 3,162 times

Last updated: Jul 12 '15