Could not initialize robot simulation interface in ROS Indigo

asked 2015-07-08 01:20:02 -0500

Lentin gravatar image

updated 2015-07-08 03:59:22 -0500

gvdhoorn gravatar image

Hi all

I am getting a strange error while spawning gazebo model in ROS Indigo. I am using Ubuntu 14.04.2 , 64 bit. After a recent update of ROS Indigo, i am getting this error while spawning in Gazebo model. I have tried with RRbot and some other robot in which gazebo spawning working properly.I have setup the same environment in virtualbox and it is working good. Please give any suggestions. I hope its not the issue with URDF

[ INFO] [1436335163.940708762, 6.729000000]: Loading gazebo_ros_control plugin
[ INFO] [1436335163.941087821, 6.729000000]: Starting gazebo_ros_control plugin in namespace: /safe_arm
[ INFO] [1436335163.942888724, 6.729000000]: gazebo_ros_control plugin is waiting for model URDF in parameter [/robot_description] on the ROS param server. 
[FATAL]   [1436335164.281192642, 6.729000000]: Could not initialize robot simulation interface
edit retag flag offensive close merge delete

Comments

I am facing the same problem, got any success in fixing it?

kunalgrover05 gravatar image kunalgrover05  ( 2015-09-06 23:22:03 -0500 )edit